Bug 1406012 - banshee has invalid dependency on epel7
Summary: banshee has invalid dependency on epel7
Status: CLOSED DUPLICATE of bug 1647999
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: banshee
Version: epel7
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
Depends On: 1405994
TreeView+ depends on / blocked
Reported: 2016-12-19 13:50 UTC by Tuomo Soini
Modified: 2019-04-12 14:51 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2019-04-12 14:51:52 UTC
Type: Bug

Attachments (Terms of Use)

Description Tuomo Soini 2016-12-19 13:50:05 UTC
banshee requires 

libgpod-sharp >= 0.8.2

Unfortunately this package is provided by libgpod-0.8.3-14.el7.

Problem is, that version if against epel7 policy and I have requested removing that package which updates rhel7 libgpod-0.8.2-11.el7.

That means there must be new package which is not libgpod providing libgpod-sharp or banshee gets removed from epel7 because of missing dependencies.

Comment 1 philip.deboer 2017-08-25 13:55:51 UTC
This still seems to be an issue. I am seeing
Package libgpod-0.8.2-12.el7.x86_64 already installed and latest version

but it is not satisfying the requirement for libgpod-sharp.

Is there a workaround until this is addressed?

Comment 3 Orion Poplawski 2017-08-25 16:46:51 UTC
Someone will need to submit a libgpod-sharp package for EPEL to provide the sharp bindings.

Comment 4 Moez Roy 2017-09-06 21:27:31 UTC
(In reply to Orion Poplawski from comment #3)
> Someone will need to submit a libgpod-sharp package for EPEL to provide the
> sharp bindings.

Well you removed it so...

Comment 5 Tom "spot" Callaway 2017-09-07 12:26:48 UTC
I feel like this is covered with: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-87f6cddc6b

Comment 6 Tuomo Soini 2017-09-08 06:40:00 UTC
No. That update can't go to epel7 because libgpod is now part of rhel7.4.

So there should be new package libgpod-sharp which only would provide needed sharp extension for libgpod.

Comment 7 Troy Dawson 2019-04-12 14:51:52 UTC

*** This bug has been marked as a duplicate of bug 1647999 ***

Note You need to log in before you can comment on or make changes to this bug.