Bug 1595937

Summary: RGW Memory Leak
Product: Red Hat Ceph Storage Reporter: tserlin
Component: RGWAssignee: Matt Benjamin (redhat) <mbenjamin>
Status: CLOSED ERRATA QA Contact: Tejas <tchandra>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 3.0CC: bschmaus, cbodley, ceph-eng-bugs, ceph-qe-bugs, edonnell, kbader, kdreyer, kdudka, linuxkidd, mbenjamin, mhackett, mkogan, mwatts, owasserm, skinjo, sweil, tchandra, tserlin, vumrao
Target Milestone: z5   
Target Release: 3.0   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: RHEL: ceph-12.2.4-36.el7cp Ubuntu: ceph_12.2.4-40redhat1 Doc Type: Bug Fix
Doc Text:
.Fixed a memory leak with the Ceph Object Gateway A buffer used to transfer incoming PUT data was incorrectly sized at the maximum chunk value of 4 MB. This was leading to a space leak of unused buffer space when PUTs of smaller objects were processed. The Ceph Object Gateway can leak space when processing large numbers of PUT requests less than 4M in size. As a result, the incorrect buffer sizing logic was fixed.
Story Points: ---
Clone Of: 1522881 Environment:
Last Closed: 2018-08-09 18:27:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1522881    
Bug Blocks:    

Comment 17 errata-xmlrpc 2018-08-09 18:27:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2375