Bug 1608223

Summary: SCVMM smartstate fails with undefined method `close' for nil:NilClass
Product: Red Hat CloudForms Management Engine Reporter: Niladri Roy <niroy>
Component: SmartState AnalysisAssignee: Hui Song <hsong>
Status: CLOSED CURRENTRELEASE QA Contact: Satyajit Bulage <sbulage>
Severity: high Docs Contact:
Priority: high    
Version: 5.9.3CC: akarol, dmetzger, gblomqui, hsong, jrfuller, niroy, obarenbo, roliveri, simaishi
Target Milestone: GAKeywords: TestOnly, ZStream
Target Release: 5.10.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 5.10.0.8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1611002 (view as bug list) Environment:
Last Closed: 2019-02-11 14:18:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1611002    

Description Niladri Roy 2018-07-25 07:02:57 UTC
Description of problem:
Smartstate analysis for VMs on SCVMM fails with the below error

[----] E, [2018-07-25T07:45:18.447327 #49869:5fb108] ERROR -- : Q-task_id([job_dispatcher]) MIQ(ManageIQ::Providers::Microsoft::InfraManager::Vm.connect_to_ems): Connection to [host(directly):] failed for VM:[TestService01] with error [no Hostname defined] after [0.000695679] seconds
[----] E, [2018-07-25T07:45:18.449385 #49869:5fb108] ERROR -- : Q-task_id([job_dispatcher]) MIQ(ManageIQ::Providers::Microsoft::InfraManager::Vm#perform_metadata_scan): undefined method `close' for nil:NilClass


Version-Release number of selected component (if applicable):
5.9.3.4

How reproducible:
Everytime at Cu environment

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 24 CFME Bot 2018-08-01 00:23:23 UTC
New commit detected on ManageIQ/manageiq-providers-scvmm/master:

https://github.com/ManageIQ/manageiq-providers-scvmm/commit/c47d02ca32ef474b96edd5046583802db70a0507
commit c47d02ca32ef474b96edd5046583802db70a0507
Author:     hsong-rh <hsong>
AuthorDate: Tue Jul 31 15:47:24 2018 -0400
Commit:     hsong-rh <hsong>
CommitDate: Tue Jul 31 15:47:24 2018 -0400

    Fix to use hostname when connect to SCVMM host

    https://bugzilla.redhat.com/show_bug.cgi?id=1608223

 app/models/manageiq/providers/microsoft/infra_manager/vm_or_template_shared/scanning.rb | 4 +-
 1 file changed, 2 insertions(+), 2 deletions(-)

Comment 28 Satyajit Bulage 2018-11-06 09:41:06 UTC
Performed Steps:
1. Added SCVMM Provider
2. Updated field with Hostname and IP address
3. In both the scenarios, performed SSA on VM and found that IP to hostname conversion is happening.
4. SSA on VM succeed in both scenario.


Verified Version: 5.10.0.21.20181023151612_4c11b0d