Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: Smartstate analysis for VMs on SCVMM fails with the below error [----] E, [2018-07-25T07:45:18.447327 #49869:5fb108] ERROR -- : Q-task_id([job_dispatcher]) MIQ(ManageIQ::Providers::Microsoft::InfraManager::Vm.connect_to_ems): Connection to [host(directly):] failed for VM:[TestService01] with error [no Hostname defined] after [0.000695679] seconds [----] E, [2018-07-25T07:45:18.449385 #49869:5fb108] ERROR -- : Q-task_id([job_dispatcher]) MIQ(ManageIQ::Providers::Microsoft::InfraManager::Vm#perform_metadata_scan): undefined method `close' for nil:NilClass Version-Release number of selected component (if applicable): 5.9.3.4 How reproducible: Everytime at Cu environment Steps to Reproduce: 1. 2. 3. Actual results: Expected results: Additional info:
https://github.com/ManageIQ/manageiq-providers-scvmm/pull/79
New commit detected on ManageIQ/manageiq-providers-scvmm/master: https://github.com/ManageIQ/manageiq-providers-scvmm/commit/c47d02ca32ef474b96edd5046583802db70a0507 commit c47d02ca32ef474b96edd5046583802db70a0507 Author: hsong-rh <hsong> AuthorDate: Tue Jul 31 15:47:24 2018 -0400 Commit: hsong-rh <hsong> CommitDate: Tue Jul 31 15:47:24 2018 -0400 Fix to use hostname when connect to SCVMM host https://bugzilla.redhat.com/show_bug.cgi?id=1608223 app/models/manageiq/providers/microsoft/infra_manager/vm_or_template_shared/scanning.rb | 4 +- 1 file changed, 2 insertions(+), 2 deletions(-)
Performed Steps: 1. Added SCVMM Provider 2. Updated field with Hostname and IP address 3. In both the scenarios, performed SSA on VM and found that IP to hostname conversion is happening. 4. SSA on VM succeed in both scenario. Verified Version: 5.10.0.21.20181023151612_4c11b0d