Bug 1621255

Summary: [iscsi] purge-iscsi-gateways.yml should disable/stop all the iscsi services
Product: Red Hat Ceph Storage Reporter: Madhavi Kasturi <mkasturi>
Component: Ceph-AnsibleAssignee: Mike Christie <mchristi>
Status: CLOSED ERRATA QA Contact: Manohar Murthy <mmurthy>
Severity: medium Docs Contact: Bara Ancincova <bancinco>
Priority: medium    
Version: 3.1CC: agunn, anharris, aschoen, ceph-eng-bugs, ceph-qe-bugs, gabrioux, gmeno, hnallurv, kdreyer, mchristi, nthomas, pasik, sankarshan, shan, tnielsen, tserlin
Target Milestone: rc   
Target Release: 3.2   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: RHEL: ceph-ansible-3.2.0-0.1.rc2.el7cp Ubuntu: ceph-ansible_3.2.0~rc2-2redhat1 Doc Type: Bug Fix
Doc Text:
.Ansible now stops and disables the iSCSI gateway services when purging the Ceph iSCSI gateway Previously, the `ceph-ansible` utility did not stop and disable the Ceph iSCSI gateway services when using the `purge-iscsi-gateways.yml` playbook. Consequently, the services had to be stopped manually. The playbook has been improved, and the iSCSI services are now stopped and disabled as expected when purging the iSCSI gateway.
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-01-03 19:01:46 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1584264, 1629656    
Attachments:
Description Flags
ansible, services logs none

Comment 6 leseb 2018-10-25 11:07:57 UTC
Present in https://github.com/ceph/ceph-ansible/releases/tag/v3.2.0beta9

For the BZ, I believe it's better if you keep the assignment so if QA finds something then you will be alerted.
So if you fix something upstream in master AND backported in a stable branch AND a release (e,g: https://github.com/ceph/ceph-ansible/releases/tag/v3.2.0beta9) has the fix then you can the BZ to POST :).

Sounds good?
Thanks!

Comment 11 Madhavi Kasturi 2018-11-06 08:38:59 UTC
Created attachment 1502314 [details]
ansible, services logs

Comment 22 errata-xmlrpc 2019-01-03 19:01:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020