Bug 1622353

Summary: kf5-libkdcraw Fails to upgrade from F28 to F29
Product: [Fedora] Fedora Reporter: Miroslav Suchý <msuchy>
Component: kf5-libkdcrawAssignee: Rex Dieter <rdieter>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 28CC: awilliam, manisandro, rdieter
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: kf5-libkdcraw-18.04.3-2.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-09-11 12:43:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1596892    
Bug Blocks: 1517012    

Description Miroslav Suchý 2018-08-26 18:01:48 UTC
This holds upgrades from Fedora 28 to Fedora 29:

 Problém 7: problem with installed package kf5-libkdcraw-17.12.3-1.fc28.x86_64
  - package kf5-libkdcraw-17.12.3-1.fc28.x86_64 requires libraw.so.16()(64bit), but none of the providers can be installed
  - package kf5-libkdcraw-18.04.2-2.fc29.x86_64 requires libraw.so.16()(64bit), but none of the providers can be installed
  - cannot install both LibRaw-0.19.0-4.fc29.x86_64 and LibRaw-0.18.13-1.fc28.x86_64
  - package shotwell-0.28.4-2.fc29.x86_64 requires libraw.so.19()(64bit), but none of the providers can be installed
  - problem with installed package shotwell-0.28.4-1.fc28.x86_64
  - shotwell-0.28.4-1.fc28.x86_64 does not belong to a distupgrade repository

Comment 1 Sandro Mani 2018-08-28 21:00:57 UTC
Archlinux has a patch for building against libraw-0.19 [1], scratch build here [2].

[1] https://git.archlinux.org/svntogit/packages.git/tree/trunk/libkdcraw-libraw-0.19.patch?h=packages/libkdcraw
[2] https://koji.fedoraproject.org/koji/taskinfo?taskID=29354522

Comment 2 Rex Dieter 2018-08-28 21:43:40 UTC
Thanks!

A candidate fix was posted today that appears to work as advertised,
https://phabricator.kde.org/D15132

patched builds underway

Comment 3 Fedora Update System 2018-08-28 21:47:14 UTC
kf5-libkdcraw-18.04.3-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-ece13267d7

Comment 4 Fedora Update System 2018-08-29 19:06:02 UTC
kf5-libkdcraw-18.04.3-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-ece13267d7

Comment 5 Fedora Update System 2018-08-29 23:13:56 UTC
kf5-libkdcraw-18.04.3-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-ece13267d7

Comment 6 Adam Williamson 2018-09-04 22:38:54 UTC
Proposing for Beta FE status - much like https://bugzilla.redhat.com/show_bug.cgi?id=1623132 , same justification (affects KDE lives and upgrades).

Comment 7 Adam Williamson 2018-09-10 23:10:06 UTC
Discussed at 2018-09-10 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-09-10/f29-blocker-review.2018-09-10-16.01.html . Accepted as a freeze exception issue on the same basis as #1623132 was.

Comment 8 Fedora Update System 2018-09-11 12:43:01 UTC
kf5-libkdcraw-18.04.3-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.