Bug 1623438

Summary: [Tracking-RHGS-BZ#1623874] IO errors on block device post rebooting one brick node
Product: Red Hat Gluster Storage Reporter: Rachael <rgeorge>
Component: rhgs-server-containerAssignee: Raghavendra Talur <rtalur>
Status: CLOSED ERRATA QA Contact: Pulkit Kundra <pkundra>
Severity: high Docs Contact:
Priority: unspecified    
Version: cns-3.10CC: amukherj, asriram, hchiramm, knarra, kramdoss, madam, mchangir, pkarampu, pkundra, pprakash, prasanna.kalever, rgeorge, rhs-bugs, rtalur, vbellur, xiubli
Target Milestone: ---Keywords: ZStream
Target Release: OCS 3.11.z Batch Update 4Flags: knarra: needinfo-
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: rhgs-server-container-3.11.4-1 Doc Type: Bug Fix
Doc Text:
Previously, applications using blockvolumes hung on I/O when the target server lost connection to any of the bricks. With this fix, the hang is not observed as long as the volume still meets its quorum.
Story Points: ---
Clone Of:
: 1623874 (view as bug list) Environment:
Last Closed: 2019-10-30 12:32:53 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1623874    
Bug Blocks: 1707226    

Comment 8 Rachael 2018-08-30 11:15:54 UTC
Hi Atin,

I have tried this scenario only once.

Comment 16 RamaKasturi 2019-05-06 07:32:09 UTC
Hello Yaniv,

   I see that content now has been finalized for 3.11.3 and already in testing phase. We can take this bug in for the next release which is ocs 3.11.4.

Thanks
kasturi

Comment 17 Yaniv Kaul 2019-05-06 07:49:04 UTC
(In reply to RamaKasturi from comment #16)
> Hello Yaniv,
> 
>    I see that content now has been finalized for 3.11.3 and already in
> testing phase. We can take this bug in for the next release which is ocs
> 3.11.4.
> 
> Thanks
> kasturi

Makes little sense to me - perhaps I'm missing something. This is just a tracker - the relevant BZ has been fixed, verified and released. I'm not sure why this cannot be part of the regular testing of 3.11.3.
Perhaps I'm missing something.

Comment 39 errata-xmlrpc 2019-10-30 12:32:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3257