Bug 1625254

Summary: fluentd json_parse_exception\",\"reason\":\"Invalid UTF-8 start byte 0x92\\n at [Source: [B@12278e45; line: 1, column: 106]\"}],\"type\":\"json_parse_exception\"
Product: OpenShift Container Platform Reporter: Vítor Corrêa <vcorrea>
Component: LoggingAssignee: Jeff Cantrill <jcantril>
Status: CLOSED WONTFIX QA Contact: Anping Li <anli>
Severity: high Docs Contact:
Priority: unspecified    
Version: 3.6.0CC: ajuricic, aos-bugs, dyocum, gferrazs, jcantril, jmalde, lasilva, nnosenzo, rmeggins, tkatarki
Target Milestone: ---Keywords: Reopened
Target Release: 3.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-03-14 17:59:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Vítor Corrêa 2018-09-04 13:29:26 UTC
Description of problem:
This bug seems to be solved on 3.9: https://bugzilla.redhat.com/show_bug.cgi?id=1562004 ( errata: https://access.redhat.com/errata/RHBA-2018:2335 )

Customer is using ocp v3.6 and has tha same issue:

2018-09-03 15:10:12 -0300 [warn]: temporarily failed to flush the buffer. next_retry=2018-09-03 15:15:10 -0300 error_class="Elasticsearch::Transport::Transport::Errors::InternalServerError" error="[500] {\"error\":{\"root_cause\":[{\"type\":\"json_parse_exception\",\"reason\":\"Invalid UTF-8 start byte 0x92\\n at [Source: [B@12278e45; line: 1, column: 106]\"}],\"type\":\"json_parse_exception\",\"reason\":\"Invalid UTF-8 start byte 0x92\\n at [Source: [B@12278e45; line: 1, column: 106]\"},\"status\":500}" plugin_id="object:b0df74"


I would like to request the analysis of a backport for 3.6. 


Regards

Comment 9 Jeff Cantrill 2018-09-06 12:55:20 UTC
Actually, I believe we backported this change into 3.7 along with numerous other fixes to fluent to make it significantly more stable.

Comment 12 Jeff Cantrill 2018-09-06 21:13:26 UTC
Correct

Comment 25 Jeff Cantrill 2019-02-01 09:27:16 UTC
Closing as no additional information for some time.

Comment 26 Nicolas Nosenzo 2019-02-01 12:50:40 UTC
(In reply to Jeff Cantrill from comment #25)
> Closing as no additional information for some time.

Ok, will let you know in case the issue persists. Thanks for the help.

Comment 29 Jeff Cantrill 2019-03-14 17:59:54 UTC
Closing WONTFIX. Current open issue: https://bugzilla.redhat.com/show_bug.cgi?id=1654704