Bug 162550

Summary: broken Requires: libpixman-devel >= %{pixman_version}
Product: [Fedora] Fedora Reporter: Michael Schwendt <bugs.michael>
Component: cairoAssignee: Kristian Høgsberg <krh>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-06 10:49:04 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Michael Schwendt 2005-07-06 04:09:13 EDT
Undefined RPM macro %{pixman_version} found in package dependencies:

$ rpm --query cairo-devel
cairo-devel-0.5.1-4

$ rpm --query --requires cairo-devel
cairo = 0.5.1-4
fontconfig-devel >= 2.0
freetype-devel >= 2.1.3-3
libpixman-devel >= %{pixman_version}
libpng-devel  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
xorg-x11-devel  

Solution: Either define pixman_version in the spec or delete this minimum version.
Comment 1 Kristian Høgsberg 2005-07-06 10:49:04 EDT
Michael,

Thanks for pointing this out.  I already define libpixman_version, which is what
this macro should have been. cairo-0.5.1-5 has the fix and should be in rawhide
soon.