Bug 1626622

Summary: readelf --unwind not supported
Product: [Fedora] Fedora Reporter: Ben Woodard <woodard>
Component: binutilsAssignee: Nick Clifton <nickc>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: rawhideCC: aoliva, dvlasenk, fweimer, jakub, law, nickc, ohudlick, qe-baseos-tools-bugs, tgummels
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: aarch64   
OS: Linux   
Whiteboard:
Fixed In Version: binutils-2.31.1-17.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1626614 Environment:
Last Closed: 2019-02-02 03:35:30 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 967086    

Description Ben Woodard 2018-09-07 18:02:18 UTC
+++ This bug was initially created as a clone of Bug #1626614 +++

Description of problem:
[ben@ulna2:~]$ readelf --unwind /usr/lib64/libm.so

The decoding of unwind sections for machine type AArch64 is not currently supported.


Version-Release number of selected component (if applicable):
binutils-2.27-28.base.el7_5.1.aarch64

How reproducible:
always

Steps to Reproduce:
see above.

Actual results:
The decoding of unwind sections for machine type AArch64 is not currently supported.


Expected results:
a dump of the .eh_frame section.

Additional info:
http://post-office.corp.redhat.com/archives/tools/2016-August/msg00054.html
May be slightly related to: https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%207

--- Additional comment from Red Hat Bugzilla Rules Engine on 2018-09-07 13:48:08 EDT ---

Since this bug report was entered in Red Hat Bugzilla, the release flag has been set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from Ben Woodard on 2018-09-07 13:51:05 EDT ---

oops may be related to: https://bugzilla.redhat.com/show_bug.cgi?id=1626614

Comment 1 Ben Woodard 2018-09-07 18:03:32 UTC
This is also true of the latest fedora package binutils-2.29.1-23.fc28.aarch64

Comment 3 Fedora Update System 2019-01-30 12:46:26 UTC
binutils-2.31.1-17.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ba3cbcfd20

Comment 4 Fedora Update System 2019-01-31 02:30:18 UTC
binutils-2.31.1-17.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-ba3cbcfd20

Comment 5 Fedora Update System 2019-02-02 03:35:30 UTC
binutils-2.31.1-17.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.