Bug 1626614 - [LLNL 7.7 FEAT] readelf --unwind not supported
Summary: [LLNL 7.7 FEAT] readelf --unwind not supported
Keywords:
Status: CLOSED DUPLICATE of bug 1640745
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: binutils
Version: 8.2
Hardware: aarch64
OS: Linux
unspecified
medium
Target Milestone: rc
: 8.2
Assignee: Nick Clifton
QA Contact: qe-baseos-tools-bugs
URL:
Whiteboard:
Depends On:
Blocks: 1563291 1593423 1746605 1640745
TreeView+ depends on / blocked
 
Reported: 2018-09-07 17:48 UTC by Ben Woodard
Modified: 2019-11-05 16:47 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1626622 1640745 (view as bug list)
Environment:
Last Closed: 2019-11-05 16:47:54 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1626622 0 unspecified CLOSED readelf --unwind not supported 2021-02-22 00:41:40 UTC

Internal Links: 1626622

Description Ben Woodard 2018-09-07 17:48:03 UTC
Description of problem:
[ben@ulna2:~]$ readelf --unwind /usr/lib64/libm.so

The decoding of unwind sections for machine type AArch64 is not currently supported.


Version-Release number of selected component (if applicable):
binutils-2.27-28.base.el7_5.1.aarch64

How reproducible:
always

Steps to Reproduce:
see above.

Actual results:
The decoding of unwind sections for machine type AArch64 is not currently supported.


Expected results:
a dump of the .eh_frame section.

Additional info:
http://post-office.corp.redhat.com/archives/tools/2016-August/msg00054.html
May be slightly related to: https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%207

Comment 2 Ben Woodard 2018-09-07 17:51:05 UTC
oops may be related to: https://bugzilla.redhat.com/show_bug.cgi?id=1626614

Comment 3 Ben Woodard 2018-09-07 19:49:15 UTC
Whoa this isn't just ARM evidently we can't process x86_64 either
[ben@Mustang ~]$ readelf -u /usr/lib64/libm.so.6 

The decoding of unwind sections for machine type Advanced Micro Devices X86-64 is not currently supported.

I thought it was just an ARM thing.

[ben@Mustang ~]$ rpm -q binutils
binutils-2.29.1-23.fc28.x86_64

Comment 4 Ben Woodard 2018-09-07 20:05:49 UTC
Useful information on how to read the .eh_frame section:
https://www.airs.com/blog/archives/460

Maybe the best plan is to extend readelf to process the .eh_frame sections for unwind info.

Comment 5 Ben Woodard 2018-09-11 00:48:32 UTC
A workaround is readelf -wF or -wf however, it is unclear to me why -u isn't wired up to do the same thing as -wf. Is that something worth considering?

Comment 6 Nick Clifton 2018-09-18 16:15:11 UTC
Hi Ben,

  Would you be terribly upset if I delayed this bug to say RHEL 7.7 ?

  It is a new feature request and I would prefer to have the feature
  implemented upstream first and then backported once it has been
  tested a bit...

Cheers
  Nick

Comment 7 Ben Woodard 2018-09-18 19:45:48 UTC
(In reply to Nick Clifton from comment #6)
> Hi Ben,
> 
>   Would you be terribly upset if I delayed this bug to say RHEL 7.7 ?

For this one — not a problem.

> 
>   It is a new feature request and I would prefer to have the feature
>   implemented upstream first and then backported once it has been
>   tested a bit...
> 
> Cheers
>   Nick

Comment 8 Ben Woodard 2018-10-18 16:22:11 UTC
The reason for this bug is that there is evidently a problem with the AARCH64 unwind information in some cases and the information doesn't match the .eh_frame debug data. I was hoping to use this feature to help debug the problem. I was unable to spot the problem when I was doing some testing and so the customer promised me a reproducer but got tied up with other problems. So the original problem report is on hold for the time being.

Even having a prototype decoder would be helpful when this problem report pops back up again.

Comment 10 Nick Clifton 2019-11-05 16:47:54 UTC

*** This bug has been marked as a duplicate of bug 1640745 ***


Note You need to log in before you can comment on or make changes to this bug.