Bug 1626994

Summary: split-brain observed on parent dir
Product: [Community] GlusterFS Reporter: Ravishankar N <ravishankar>
Component: replicateAssignee: Ravishankar N <ravishankar>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: mainlineCC: bugs, pasik
Target Milestone: ---Keywords: Translation
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: glusterfs-6.0 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1633625 1633634 1638163 (view as bug list) Environment:
Last Closed: 2018-11-20 08:49:26 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1633625, 1633634, 1638163    

Description Ravishankar N 2018-09-10 09:12:48 UTC
Description of problem:

Reported downstream via BZ 1610743.
When a directory only has dirty xattrs set (due to fop failing due to quorum not met, say), heal-info shows the directory to be in split-brain. After heal is over, it goes away though,

Comment 1 Worker Ant 2018-09-10 09:15:02 UTC
REVIEW: https://review.gluster.org/21135 (afr: don't consider 'dirty' as split-brain in heal info) posted (#1) for review on master by Ravishankar N

Comment 2 Worker Ant 2018-09-21 16:36:02 UTC
COMMIT: https://review.gluster.org/21135 committed in master by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- afr: fix incorrect reporting of directory split-brain

Problem:
When a directory has dirty xattrs due to failed post-ops or when
replace/reset brick is performed, AFR does a conservative merge as
expected, but heal-info reports it as split-brain because there are no
clear sources.

Fix:
Modify pending flag to contain information about pending heals and
split-brains. For directories, if spit-brain flag is not set,just show
them as needing heal and not being in split-brain.

Fixes: bz#1626994
Change-Id: I09ef821f6887c87d315ae99e6b1de05103cd9383
Signed-off-by: Ravishankar N <ravishankar@redhat.com>

Comment 3 Shyamsundar 2019-03-25 16:30:38 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/