Bug 1638163 - split-brain observed on parent dir
Summary: split-brain observed on parent dir
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On: 1626994
Blocks: 1633625 1633634
TreeView+ depends on / blocked
 
Reported: 2018-10-11 01:08 UTC by Ravishankar N
Modified: 2018-10-23 15:20 UTC (History)
2 users (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1626994
Environment:
Last Closed: 2018-10-23 15:20:19 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ravishankar N 2018-10-11 01:08:33 UTC
+++ This bug was initially created as a clone of Bug #1626994 +++

Description of problem:

Reported downstream via BZ 1610743.
When a directory only has dirty xattrs set (due to fop failing due to quorum not met, say), heal-info shows the directory to be in split-brain. After heal is over, it goes away though,

--- Additional comment from Worker Ant on 2018-09-10 05:15:02 EDT ---

REVIEW: https://review.gluster.org/21135 (afr: don't consider 'dirty' as split-brain in heal info) posted (#1) for review on master by Ravishankar N

--- Additional comment from Worker Ant on 2018-09-21 12:36:02 EDT ---

COMMIT: https://review.gluster.org/21135 committed in master by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- afr: fix incorrect reporting of directory split-brain

Problem:
When a directory has dirty xattrs due to failed post-ops or when
replace/reset brick is performed, AFR does a conservative merge as
expected, but heal-info reports it as split-brain because there are no
clear sources.

Fix:
Modify pending flag to contain information about pending heals and
split-brains. For directories, if spit-brain flag is not set,just show
them as needing heal and not being in split-brain.

Fixes: bz#1626994
Change-Id: I09ef821f6887c87d315ae99e6b1de05103cd9383
Signed-off-by: Ravishankar N <ravishankar@redhat.com>

Comment 1 Worker Ant 2018-10-11 01:54:02 UTC
REVIEW: https://review.gluster.org/21388 (afr: fix incorrect reporting of directory split-brain) posted (#1) for review on release-5 by Ravishankar N

Comment 2 Worker Ant 2018-10-11 11:00:33 UTC
COMMIT: https://review.gluster.org/21388 committed in release-5 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- afr: fix incorrect reporting of directory split-brain

Backport of https://review.gluster.org/#/c/glusterfs/+/21135/

Problem:
When a directory has dirty xattrs due to failed post-ops or when
replace/reset brick is performed, AFR does a conservative merge as
expected, but heal-info reports it as split-brain because there are no
clear sources.

Fix:
Modify pending flag to contain information about pending heals and
split-brains. For directories, if spit-brain flag is not set,just show
them as needing heal and not being in split-brain.

Change-Id: I09ef821f6887c87d315ae99e6b1de05103cd9383
fixes: bz#1638163
Signed-off-by: Ravishankar N <ravishankar@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:20:19 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.