Bug 162843

Summary: nfsv4 kernel error on fedora 4: xdr error 10008
Product: [Fedora] Fedora Reporter: Kevac Marko <mkevac>
Component: nfs-utilsAssignee: Steve Dickson <steved>
Status: CLOSED NOTABUG QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: igeorgex, sergio.pasra
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-11 10:36:33 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Kevac Marko 2005-07-10 05:21:35 EDT
+++ This bug was initially created as a clone of Bug #142813 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
when trying to mount a nfs4 filesystem on another remote fedora core 3
(FC3), i got the following error repeated on the client syslog :
Dec 10 15:46:27 filer2 kernel: decode_getfattr: xdr error 10008!
Dec 10 15:46:43 filer2 kernel: decode_getfattr: xdr error 10008!

... while the mount command seems to be "freezed" (but interruptible
by ^C). So any of my attempts to mount with nfs4 failed.

Here is the config on both nodes:
kernel 2.6.9 compiled from tarballs from kernel.org, all nfs option
compiled-in the kernel itself.
Fedora Core 3 with unmodified tools (FC3 seems to natively support nfs4)
both portmaps on client and server listen only to localhost
(vanemery's doc allow access to portmap only to localhost, so i think
it does the same)

Server: nfs export of a XFS partition
$ cat /etc/exports
/vol/0/nfsroot  10.0.0.0/24(ro,fsid=0,insecure,no_subtree_check,sync)

The mount command on the client was:
mount -t nfs4 -o ro,intr 10.0.0.58:/ /home/

i used the AUTH_SYS method described step by step on the vanemery tutorial
(http://www.vanemery.com/Linux/NFSv4/NFSv4-no-rpcsec.html)
except the "acl" mount option because xfs doesn't accept it. (i think
xfs supports ACLs natively)

anyone has an idea about the "xdr error 10008" error ?

Thanks in advance, 

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Mount an nfsv4 filesystem
2.
3.
    

Additional info: I`v got same bug in fc4 with nfs-utils-1.0.7-8
Comment 1 Steve Dickson 2005-07-11 06:10:23 EDT
"decode_getfattr: xdr error 10008" means the server is
waiting for some type internal request to complete
(like an uid mapping request to rpc.idmapd). When this happens
make sure idmapd is started and if it is, try restarting
it (i.e. server rpcidmapd restart). The problem should
go way... 
Comment 2 Kevac Marko 2005-07-11 10:36:33 EDT
After system reboot problem never repeated. Sorry.