Bug 1636560

Summary: Black screen when using RDP in Remote Desktop viewer
Product: [Fedora] Fedora Reporter: Alex <noriegafam>
Component: vinagreAssignee: Felipe Borges <feborges>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 28CC: amigadave, cfergeau, debarshir, feborges, federico.chia, fran, jadahl, marcandre.lureau, pokorra.mailinglists, rbarlow
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: vinagre-3.22.0-12.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-12-02 08:27:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Alex 2018-10-05 16:57:52 UTC
Description of problem:When trying to connect to remote windows servers after being prompted for credentials, the session opens up but only get a black screen. It works when using Remmina app. but not with included Remote Desktop viewer. It worked before.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Open Remote Desktop viewer
2.type server address or name
3.enter credentials when prompted.

Actual results:Able to log in (remote session) but to a black desktop screen


Expected results:Remote session to a normal working desktop.


Additional info: Using Dual Screen setup, worked in the past. Different client works

Comment 1 Jonas Ådahl 2018-10-05 17:05:08 UTC
The "Remote Desktop" viewer I assume is Vinagre. This component (gnome-remote-desktop) is a remote desktop server, not client. Moving to vinagre.

Comment 2 Alex 2018-10-05 17:48:29 UTC
(In reply to Jonas Ådahl from comment #1)
> The "Remote Desktop" viewer I assume is Vinagre. This component
> (gnome-remote-desktop) is a remote desktop server, not client. Moving to
> vinagre.

You are right! is Vinagre. Thank you for the correction!

Comment 3 Federico Chiacchiaretta 2018-10-16 08:15:09 UTC
I can confirm the bug, IIRC it happens in vinagre since freerdp has been updated to version 2.0.0 rc3 (I was on fedora 28 then, now on fedora 29 still happens).


Using a simple profile.rdp file and connecting via

$ xfreerdp profile.rdp

works properly, so the problem appears to be in vinagre itself.

Best,
Federico Chiacchiaretta

Comment 4 Francisco de la Peña 2018-10-27 23:52:08 UTC
This issue also affects gnome-boxes RDP on Fedora 29

Comment 5 Francisco de la Peña 2018-10-28 00:23:40 UTC
Upstream FreeRDP bug: https://github.com/FreeRDP/FreeRDP/issues/4864

Comment 6 Fedora Update System 2018-11-30 17:26:57 UTC
vinagre-3.22.0-12.fc29 freerdp-2.0.0-47.rc4.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-3b16389936

Comment 7 Fedora Update System 2018-11-30 17:27:28 UTC
freerdp-2.0.0-47.rc4.fc28 vinagre-3.22.0-12.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-ea25330452

Comment 8 Fedora Update System 2018-12-01 01:38:20 UTC
freerdp-2.0.0-47.rc4.fc28, vinagre-3.22.0-12.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-ea25330452

Comment 9 Fedora Update System 2018-12-01 02:43:26 UTC
freerdp-2.0.0-47.rc4.fc29, vinagre-3.22.0-12.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-3b16389936

Comment 10 Fedora Update System 2018-12-02 08:27:35 UTC
freerdp-2.0.0-47.rc4.fc29, vinagre-3.22.0-12.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Randy Barlow 2018-12-11 17:04:09 UTC
A Fedora update associated with this bug has been pushed to the stable repository.

Comment 12 Randy Barlow 2018-12-14 20:41:19 UTC
A Fedora update associated with this bug has been pushed to the stable repository.