Bug 1653214

Summary: Record permanent mac address when device is enslaved in a bond, or else /etc/mac-addresses will record broken information
Product: Red Hat Enterprise Linux 7 Reporter: Renaud Métrich <rmetrich>
Component: rearAssignee: Pavel Cahyna <pcahyna>
Status: CLOSED ERRATA QA Contact: David Jež <djez>
Severity: medium Docs Contact:
Priority: urgent    
Version: 7.6CC: djez, fkrska, ovasik, pcahyna, rmetrich
Target Milestone: rcKeywords: ZStream
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1657739 1663436 (view as bug list) Environment:
Last Closed: 2019-08-06 13:12:05 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1660473, 1630919, 1657739, 1663436    

Description Renaud Métrich 2018-11-26 09:35:01 UTC
Description of problem:

See https://github.com/rear/rear/pull/1954.

When a physical device is enslaved in a bond, its MAC address is modified to the first network interface's MAC address of the bond. This makes /etc/mac-addresses record an invalid information, e.g.:

Broken:
eth1-bond0 52:54:00:31:e0:b9
eth2-bond0 52:54:00:31:e0:b9
eth0 52:54:00:a3:97:5b

Expected:
eth1-bond0 52:54:00:31:e0:b9
eth2-bond0 52:54:00:86:ec:a8
eth0 52:54:00:a3:97:5b


Version-Release number of selected component (if applicable):

All rear releases


Additional info:

This is required for unattended restoration to be possible.

Comment 14 errata-xmlrpc 2019-08-06 13:12:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2273