Bug 1661294

Summary: Error after upgrade on subscription page
Product: Red Hat Satellite Reporter: Mike McCune <mmccune>
Component: Subscription ManagementAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED ERRATA QA Contact: jcallaha
Severity: unspecified Docs Contact:
Priority: urgent    
Version: 6.4.0CC: akofink, egolov, mvanderw
Target Milestone: 6.4.2Keywords: PrioBumpGSS, Regression, Triaged
Target Release: Unused   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: tfm-rubygem-katello-3.7.0.44-1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1648252 Environment:
Last Closed: 2019-02-13 19:08:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 1 Evgeni Golov 2019-01-10 12:22:12 UTC
Andrew, can you please make the cherrypick of this ontop of https://gitlab.sat.engineering.redhat.com/satellite6/katello/tree/SATELLITE-6.4.0?

Comment 3 jcallaha 2019-01-31 14:13:03 UTC
Verified in Satellite 6.4.2 Snap 1

Followed the steps outlined in the initial report:
1. Install Satellite 6.3 from CDN
2. Import Manifest and Upload in Satellite 
3. Add RHEL7 and sat-tools repos
4. Create CV and publish promote it.
5. Create Activation Key
6. Added Content Host to Satellite Server and Subscribe and Install Katello-agent on content host  
7. Update the Satellite Server

After a successful upgrade, navigating to the subscriptions page produced no errors.
See attached video for verification.

Comment 6 errata-xmlrpc 2019-02-13 19:08:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0345