Bug 1661739

Summary: SELinux is preventing abrt-handle-eve from 'open' accesses on the file /var/spool/abrt/oops-2018-12-20-21:31:39-1093-0/time.
Product: [Fedora] Fedora Reporter: Mikhail <mikhail.v.gavrilov>
Component: selinux-policyAssignee: Zdenek Pytela <zpytela>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dwalsh, lvrabec, mgrepl, plautrba, zpytela
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:861b3baebb45fd4988ff0d01d1b6da733bf863d6bc42c8bdb82963ce12b28ad3;VARIANT_ID=workstation;
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-12-25 11:00:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mikhail 2018-12-22 19:19:35 UTC
Description of problem:
SELinux is preventing abrt-handle-eve from 'open' accesses on the file /var/spool/abrt/oops-2018-12-20-21:31:39-1093-0/time.

*****  Plugin restorecon (99.5 confidence) suggests   ************************

If you want to fix the label. 
/var/spool/abrt/oops-2018-12-20-21:31:39-1093-0/time default label should be abrt_var_cache_t.
Then you can run restorecon. The access attempt may have been stopped due to insufficient permissions to access a parent directory in which case try to change the following command accordingly.
Do
# /sbin/restorecon -v /var/spool/abrt/oops-2018-12-20-21:31:39-1093-0/time

*****  Plugin catchall (1.49 confidence) suggests   **************************

If you believe that abrt-handle-eve should be allowed open access on the time file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'abrt-handle-eve' --raw | audit2allow -M my-abrthandleeve
# semodule -X 300 -i my-abrthandleeve.pp

Additional Information:
Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                system_u:object_r:unlabeled_t:s0
Target Objects                /var/spool/abrt/oops-2018-12-20-21:31:39-1093-0/ti
                              me [ file ]
Source                        abrt-handle-eve
Source Path                   abrt-handle-eve
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.3-15.fc30.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.20.0-0.rc7.git1.1.fc30.x86_64 #1
                              SMP Tue Dec 18 22:52:01 UTC 2018 x86_64 x86_64
Alert Count                   1
First Seen                    2018-12-23 00:17:11 +05
Last Seen                     2018-12-23 00:17:11 +05
Local ID                      df30b5dc-4944-46f8-b8b4-f6d3fa8b6098

Raw Audit Messages
type=AVC msg=audit(1545506231.484:376): avc:  denied  { open } for  pid=15230 comm="abrt-handle-eve" path="/var/spool/abrt/oops-2018-12-20-21:31:39-1093-0/time" dev="nvme0n1p2" ino=3283360 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:unlabeled_t:s0 tclass=file permissive=1


Hash: abrt-handle-eve,abrt_t,unlabeled_t,file,open

Version-Release number of selected component:
selinux-policy-3.14.3-15.fc30.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.7
hashmarkername: setroubleshoot
kernel:         4.20.0-0.rc7.git1.1.fc30.x86_64
type:           libreport

Comment 1 Zdenek Pytela 2018-12-25 11:00:55 UTC
Seems to be a duplicate of bz 1661735.

Hence closing, feel free to reopen this bugzilla if the issue turns out to be different.

*** This bug has been marked as a duplicate of bug 1661735 ***