Bug 1670125

Summary: Red Hat Repositories does not show enabled repositories list with search criteria 'Enabled/Both'
Product: Red Hat Satellite Reporter: vijsingh
Component: RepositoriesAssignee: Samir Jha <sajha>
Status: CLOSED ERRATA QA Contact: vijsingh
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.5.0CC: ahumbe, ehelms, parmstro, sajha, vijsingh
Target Milestone: 6.5.0Keywords: Regression, TestBlocker, UserExperience
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: tfm-rubygem-katello-3.10.0.24-1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-05-14 12:39:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
related screenshots none

Description vijsingh 2019-01-28 16:15:51 UTC
Description of problem:

Red Hat Repositories does not show enabled repositories list with search criteria 'Enabled/Both'

Version-Release number of selected component (if applicable):

Satellite 6.5 snap 13

How reproducible:
Always

Steps to Reproduce:
 
1. On Satellite GUI:
  Go to 'Content => Red Hat Repositories => Enable some repositories 
   Note: Default filter type is = 'RPM'

2. In Search bar(right side) select => Enabled/Both => Click on 'Search'


Actual results:

under Enabled Repositories it shows "No enabled repositories match your search criteria."


Expected results:

Enabled repositories should show with search criteria "Enabled/Both"

Additional info:

Enabled Repositories shows if you select as below in Search

  In Search bar(right side) select => Available => Click on 'Search'

Comment 4 vijsingh 2019-01-28 16:20:02 UTC
Created attachment 1524292 [details]
related screenshots

Comment 5 Samir Jha 2019-01-30 17:12:38 UTC
Created redmine issue http://projects.theforeman.org/issues/25946 from this bug

Comment 6 Bryan Kearney 2019-02-12 17:07:47 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/25946 has been resolved.

Comment 7 Ashish Humbe 2019-02-19 03:54:27 UTC
*** Bug 1678306 has been marked as a duplicate of this bug. ***

Comment 12 vijsingh 2019-03-04 12:43:05 UTC
ON_QA Verified:

Satellite snap_6.5.0_18.0

Steps:

 Content => Red Hat Repositories => Enable some repositories  In Search bar(right side) selected => Enabled/Both => Click on 'Search'

Observation:

 Able to see repositories with search criteria "Enabled/Both"

Comment 16 errata-xmlrpc 2019-05-14 12:39:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:1222