Due to a recent update on Javascript code a full page refresh on your browser might be needed.

Bug 1674143

Summary: youtube-dl missing python34-setuptools dependency
Product: [Fedora] Fedora EPEL Reporter: IanB <bugzilla.blk>
Component: youtube-dlAssignee: Till Maas <opensource>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel7CC: 4kuchibh, nerijus, opensource, rafalzaq, spacewar, tim
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: youtube-dl-2019.07.30-1.fc30 youtube-dl-2019.07.30-1.fc29 youtube-dl-2019.07.30-1.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-08-01 03:00:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description IanB 2019-02-09 11:03:53 UTC
Description of problem:

youtube-dl-2018.12.17-1.el7 requires dependency python34-setuptools however that package is not automatically installed. Without that dependency youtube-dl fails to run with error:

$ youtube-dl
Traceback (most recent call last):
  File "/usr/bin/youtube-dl", line 6, in <module>
    from pkg_resources import load_entry_point
ImportError: No module named 'pkg_resources'


youtube-dl RPM package should be modified to include python34-setuptools as a dependency.

Comment 1 Till Maas 2019-04-25 01:22:52 UTC
*** Bug 1680518 has been marked as a duplicate of this bug. ***

Comment 2 Nerijus Baliƫnas 2019-07-02 16:51:13 UTC
The package was rebuilt to change main python from 3.4 to 3.6, so it now should require python36-setuptools.

Comment 3 Fedora Update System 2019-07-30 21:12:37 UTC
FEDORA-EPEL-2019-7c4fe32880 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-7c4fe32880

Comment 4 Fedora Update System 2019-07-30 21:12:37 UTC
FEDORA-2019-284a11675f has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-284a11675f

Comment 5 Fedora Update System 2019-07-30 21:12:45 UTC
FEDORA-2019-1f090735a1 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-1f090735a1

Comment 6 Fedora Update System 2019-07-30 21:12:54 UTC
FEDORA-2019-7e148e7790 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-7e148e7790

Comment 7 Fedora Update System 2019-07-31 01:31:30 UTC
youtube-dl-2019.07.30-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-7e148e7790

Comment 8 Fedora Update System 2019-07-31 03:40:34 UTC
youtube-dl-2019.07.30-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-284a11675f

Comment 9 Fedora Update System 2019-07-31 03:48:14 UTC
youtube-dl-2019.07.30-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-7c4fe32880

Comment 10 Fedora Update System 2019-08-01 03:00:13 UTC
youtube-dl-2019.07.30-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2019-08-02 02:45:39 UTC
youtube-dl-2019.07.30-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2019-08-15 17:35:54 UTC
youtube-dl-2019.07.30-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.