Bug 1680518 - youtube-dl should require python34-setuptools
Summary: youtube-dl should require python34-setuptools
Keywords:
Status: CLOSED DUPLICATE of bug 1674143
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: youtube-dl
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Till Maas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-25 09:30 UTC by Nerijus Baliūnas
Modified: 2019-04-25 01:22 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-25 01:22:52 UTC
Type: Bug


Attachments (Terms of Use)

Description Nerijus Baliūnas 2019-02-25 09:30:31 UTC
$ rpm -q --requires youtube-dl 
/usr/bin/python3.4
config(youtube-dl) = 2019.01.30-1.el7
python(abi) = 3.4
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1

$ youtube-dl 
Traceback (most recent call last):
  File "/usr/bin/youtube-dl", line 6, in <module>
    from pkg_resources import load_entry_point
ImportError: No module named 'pkg_resources'

After installing python34-setuptools youtube-dl launches.

Comment 1 Till Maas 2019-04-25 01:22:52 UTC
Thank you for your report!

*** This bug has been marked as a duplicate of bug 1674143 ***


Note You need to log in before you can comment on or make changes to this bug.