Bug 1685219

Summary: Operator should use imagePullPolicy: IfNotPresent
Product: OpenShift Container Platform Reporter: Clayton Coleman <ccoleman>
Component: AuthAssignee: Erica von Buelow <evb>
Status: CLOSED ERRATA QA Contact: Chuan Yu <chuyu>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.1.0CC: aos-bugs, nagrawal
Target Milestone: ---   
Target Release: 4.1.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1685224 (view as bug list) Environment:
Last Closed: 2019-06-04 10:44:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1685224, 1685225, 1685227, 1685228, 1685229, 1685230, 1685232    

Description Clayton Coleman 2019-03-04 17:03:03 UTC
Use imagePullPolicy: IfNotPresent instead of always in:

["openshift-authentication-operator","openshift-authentication-operator-bc94f484c-252mt"]

Comment 4 Chuan Yu 2019-03-14 03:46:30 UTC
Verified.

$ oc get deployment -n openshift-authentication-operator -o json | jq '.items[0].spec.template.spec.containers[0].imagePullPolicy' 
"IfNotPresent"

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-03-13-233958   True        False         24m     Cluster version is 4.0.0-0.nightly-2019-03-13-233958

Comment 6 errata-xmlrpc 2019-06-04 10:44:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758