Bug 1685232 - Operator should use imagePullPolicy: IfNotPresent
Summary: Operator should use imagePullPolicy: IfNotPresent
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Catalog
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Dan Geoffroy
QA Contact: Jian Zhang
URL:
Whiteboard:
: 1686899 (view as bug list)
Depends On: 1685219 1685224 1685225 1685227 1685228 1685229 1685230
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-04 17:39 UTC by Clayton Coleman
Modified: 2019-06-04 10:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1685230
: 1685233 (view as bug list)
Environment:
Last Closed: 2019-06-04 10:45:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:45:12 UTC

Description Clayton Coleman 2019-03-04 17:39:35 UTC
+++ This bug was initially created as a clone of Bug #1685219 +++

Use imagePullPolicy: IfNotPresent instead of always in:

["openshift-svcat-apiserver-operator","openshift-svcat-apiserver-operator-757d7c59fb-rxlc4"]
["openshift-svcat-controller-manager-operator","openshift-svcat-controller-manager-operator-6bbc8b4-xq97g"]

Comment 3 Jian Zhang 2019-03-11 08:05:36 UTC
The current payload hasn't merged this fixed PR, change Status to MODIFIED.
Cluster version is 4.0.0-0.nightly-2019-03-06-074438

Comment 5 Jian Zhang 2019-03-14 07:47:20 UTC
LGTM, verify it.

Current version: 4.0.0-0.nightly-2019-03-13-233958
[jzhang@dhcp-140-18 ocp14]$ oc get pods -o yaml -n openshift-service-catalog-apiserver-operator |grep image
      image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:3040cca229368a69d2b8f6f26574caf4aa48605cd3a6c73b20bf17dc560a67e8
      imagePullPolicy: IfNotPresent

[jzhang@dhcp-140-18 ocp14]$ oc get pods -o yaml -n openshift-service-catalog-controller-manager-operator |grep image
      image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:177ec278a9f9c1de396dda293337029c828e43430ae11faff8316cad07a8b6b9
      imagePullPolicy: IfNotPresent

Comment 6 Jian Zhang 2019-03-14 08:30:37 UTC
*** Bug 1686899 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2019-06-04 10:45:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.