Bug 1686116

Summary: anaconda doesn't display question during text install so there's no context as to what you're responding to
Product: [Fedora] Fedora Reporter: Peter Robinson <pbrobinson>
Component: anacondaAssignee: Vendula Poncova <vponcova>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: anaconda-maint-list, jkonecny, jonathan, kellin, sjalgaon, vanmeeuwen+fedora, vponcova, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: anaconda-30.25.4-1 anaconda-30.25.4-1.fc30 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-04-04 00:01:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Peter Robinson 2019-03-06 18:30:59 UTC
If you are in a sub menu when doing a text install and select q (quit) as an option it presents you with a blank question with a yes/no answer but there's no question displayed, if you assume that it's to quit back to the main menu (which turned out to be wrong) you end up quitting the installer and the install fails.

I would expect it to display a question something to the effect of whether you want to quit the install or not to ensure the user knows they right context.

Two different screens displaying the issue:

Please make a selection from the above ['b' to begin installation, 'h' to help,
'q' to quit, 'r' to refresh]: 8
================================================================================
================================================================================
User creation

1) [ ] Create user

Please make a selection from the above ['c' to continue, 'h' to help, 'q' to
quit, 'r' to refresh]: q
================================================================================
================================================================================
Question


Please respond 'yes' or 'no': 


Press ENTER to continue:  
26) Finnish                55) Marathi                84) Yoruba
27) Filipino               56) Malay                  85) Mandarin Chinese
28) French                 57) Burmese                86) Zulu
29) Friulian               58) Norwegian Bokmål

Please select language support to install ['b' to return to language list, 'c'
to continue, 'h' to help, 'q' to quit, 'r' to refresh]: q
================================================================================
================================================================================
Question


Please respond 'yes' or 'no':

Comment 1 Vendula Poncova 2019-03-07 13:01:48 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/1876

Comment 2 Vendula Poncova 2019-03-07 14:45:19 UTC
*** Bug 1686118 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2019-04-02 16:48:34 UTC
anaconda-30.25.4-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-7f36d739dc

Comment 4 Fedora Update System 2019-04-03 02:27:38 UTC
anaconda-30.25.4-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-7f36d739dc

Comment 5 Fedora Update System 2019-04-04 00:01:55 UTC
anaconda-30.25.4-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.