Bug 1686118 - anaconda doesn't display question during text install so there's no context as to what you're responding to
Summary: anaconda doesn't display question during text install so there's no context a...
Keywords:
Status: CLOSED DUPLICATE of bug 1686116
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 30
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-06 18:32 UTC by Peter Robinson
Modified: 2019-03-07 14:45 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-07 14:45:19 UTC
Type: Bug


Attachments (Terms of Use)

Description Peter Robinson 2019-03-06 18:32:53 UTC
If you are in a sub menu when doing a text install and select q (quit) as an option it presents you with a blank question with a yes/no answer but there's no question displayed, if you assume that it's to quit back to the main menu (which turned out to be wrong) you end up quitting the installer and the install fails.

I would expect it to display a question something to the effect of whether you want to quit the install or not to ensure the user knows they right context.

Two different screens displaying the issue:

Please make a selection from the above ['b' to begin installation, 'h' to help,
'q' to quit, 'r' to refresh]: 8
================================================================================
================================================================================
User creation

1) [ ] Create user

Please make a selection from the above ['c' to continue, 'h' to help, 'q' to
quit, 'r' to refresh]: q
================================================================================
================================================================================
Question


Please respond 'yes' or 'no': 


Press ENTER to continue:  
26) Finnish                55) Marathi                84) Yoruba
27) Filipino               56) Malay                  85) Mandarin Chinese
28) French                 57) Burmese                86) Zulu
29) Friulian               58) Norwegian Bokmål

Please select language support to install ['b' to return to language list, 'c'
to continue, 'h' to help, 'q' to quit, 'r' to refresh]: q
================================================================================
================================================================================
Question


Please respond 'yes' or 'no':

Comment 1 Vendula Poncova 2019-03-07 14:45:19 UTC

*** This bug has been marked as a duplicate of bug 1686116 ***


Note You need to log in before you can comment on or make changes to this bug.