Bug 1690312 (CVE-2019-9187)

Summary: CVE-2019-9187 ikiwiki: server-side request forgery resulting in dos
Product: [Other] Security Response Reporter: Dhananjay Arunesh <darunesh>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: thomas.moschny
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-10-27 03:27:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1690314    
Bug Blocks:    

Description Dhananjay Arunesh 2019-03-19 09:39:05 UTC
The vulnerability was discovered in aggregate plugin of the Ikiwiki wiki compiler was susceptible to server-side request forgery, resulting in information disclosure or denial of service.

Reference:
https://www.openwall.com/lists/oss-security/2019/02/28/1

Upstream commit:
http://source.ikiwiki.branchable.com/?p=source.git;a=commitdiff;h=e7b0d4a
http://source.ikiwiki.branchable.com/?p=source.git;a=commitdiff;h=67543ce
http://source.ikiwiki.branchable.com/?p=source.git;a=commitdiff;h=d283e4c
http://source.ikiwiki.branchable.com/?p=source.git;a=commitdiff;h=9a275b2

Comment 1 Dhananjay Arunesh 2019-03-19 09:39:17 UTC
Created ikiwiki tracking bugs for this issue:

Affects: epel-6 [bug 1690314]

Comment 2 Dhananjay Arunesh 2019-03-19 09:40:05 UTC
External References:

https://www.debian.org/security/2019/dsa-4399