Bug 1690911

Summary: unidling unit tests need to be re-enabled
Product: OpenShift Container Platform Reporter: David Eads <deads>
Component: NetworkingAssignee: Ricardo Carrillo Cruz <ricarril>
Status: CLOSED CURRENTRELEASE QA Contact: Meng Bo <bmeng>
Severity: high Docs Contact:
Priority: medium    
Version: 4.1.0CC: aos-bugs, bbennett, cdc, decarr, erooth, lserven, minden, mloibl, surbania
Target Milestone: ---Flags: lserven: needinfo? (decarr)
Target Release: 4.1.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-05-08 12:11:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description David Eads 2019-03-20 13:06:26 UTC
To land the 1.13 rebase, the unidling controller had to be updated because the previously used clients were removed.  The new client mocks aren't compatible with the old, so we skipped the unit tests (units only) to free up the rest of the rebase.  The tests skipped in https://github.com/openshift/origin/pull/22368 need to be re-enabled.

Comment 1 David Eads 2019-03-20 13:07:20 UTC
@derek please confirm I got the right group.

Comment 2 lserven 2019-03-27 16:30:42 UTC
@Derek,

I think this bug should be owned by the autoscaling team, not the monitoring team. PTAL.

-Lucas

Comment 3 Frederic Branczyk 2019-04-04 08:39:23 UTC
As commented on the pull request, this belong to network-edge, so reassigning.

Comment 4 Dan Mace 2019-04-10 13:54:28 UTC
Spoke with Casey — Networking will handle this refactor.

Comment 5 Ricardo Carrillo Cruz 2019-04-29 10:15:27 UTC
https://github.com/openshift/origin/pull/22588

Comment 6 Ben Bennett 2019-04-30 13:04:48 UTC
Moving to 4.2 because this is not really a release blocker for 4.1.

Ricardo if this lands in 4.1 please just change the version back when you move to MODIFIED.  Thanks

Comment 8 Meng Bo 2019-05-08 11:42:14 UTC
The related unit tests were added.

Close the bug.