Bug 1699179

Summary: "Installation Source" spoke not configuring automatically
Product: [Fedora] Fedora Reporter: Geoffrey Marr <gmarr>
Component: anacondaAssignee: Jiri Konecny <jkonecny>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: anaconda-maint-list, gmarr, jkonecny, jonathan, kellin, robatino, vanmeeuwen+fedora, vponcova, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-04-12 18:40:06 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1574715    
Attachments:
Description Flags
anaconda.log
none
dbus.log
none
dnf.librepo.log
none
lvm.log
none
packaging.log
none
program.log
none
sensitive-info.log
none
storage.log
none
X.log none

Description Geoffrey Marr 2019-04-12 02:57:25 UTC
Description of problem:
"Installation Source" shows an error upon starting up

Version-Release number of selected component (if applicable):
Fedora-Server-dvd-x86_64-30-20190405.n.0

How reproducible:
Always

Steps to Reproduce:
Attempt to install Fedora from an .iso stored on a separate partition using inst.repo. See this test: 

https://fedoraproject.org/wiki/QA:Testcase_install_repository_Hard_drive_variation

Actual results:
When the graphical installer starts up and shows the hub, the "Installation Source" shows the following: "Error setting up base repository".

Expected results:
Installer should automatically configure the "Installation Source" and show no error or require any user input on that spoke.

Additional info:
If the user clicks on the "Installation Source" spoke and then presses the "Done" button without making any changes, the source is configured and works like it should. 

See attached logs from /tmp for more info.

Comment 1 Geoffrey Marr 2019-04-12 02:58:32 UTC
Created attachment 1554693 [details]
anaconda.log

Comment 2 Geoffrey Marr 2019-04-12 02:59:20 UTC
Created attachment 1554694 [details]
dbus.log

Comment 3 Geoffrey Marr 2019-04-12 02:59:43 UTC
Created attachment 1554695 [details]
dnf.librepo.log

Comment 4 Geoffrey Marr 2019-04-12 03:00:05 UTC
Created attachment 1554696 [details]
lvm.log

Comment 5 Geoffrey Marr 2019-04-12 03:00:47 UTC
Created attachment 1554697 [details]
packaging.log

Comment 6 Geoffrey Marr 2019-04-12 03:01:06 UTC
Created attachment 1554698 [details]
program.log

Comment 7 Geoffrey Marr 2019-04-12 03:01:40 UTC
Created attachment 1554699 [details]
sensitive-info.log

Comment 8 Geoffrey Marr 2019-04-12 03:02:00 UTC
Created attachment 1554700 [details]
storage.log

Comment 9 Geoffrey Marr 2019-04-12 03:02:16 UTC
Created attachment 1554701 [details]
X.log

Comment 10 Fedora Blocker Bugs Application 2019-04-12 03:05:20 UTC
Proposed as a Blocker for 30-final by Fedora user coremodule using the blocker tracking app because:

 Proposing as a blocker as this violates the following F30 Final criteria [0]:

"The installer must be able to use all supported local and remote package and installer sources. "

[0] https://fedoraproject.org/wiki/Fedora_30_Final_Release_Criteria#Package_and_installer_sources

Comment 11 Jiri Konecny 2019-04-12 09:29:19 UTC
Hello, 

The compose Fedora-Server-dvd-x86_64-30-20190405.n.0 has an old Anaconda version without the NFS ISO fix. 

Please re-test this on a newer compose.

Comment 12 Jiri Konecny 2019-04-12 09:29:55 UTC
You probably experiencing the same issue as in bug 1691832.

Comment 13 Geoffrey Marr 2019-04-12 18:40:06 UTC
Jiri, thanks, it's fixed in the Fedora-Server-dvd-x86_64-30-20190411.n.0 compose! Will close the bug.