Bug 1699179 - "Installation Source" spoke not configuring automatically
Summary: "Installation Source" spoke not configuring automatically
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jiri Konecny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F30FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2019-04-12 02:57 UTC by Geoffrey Marr
Modified: 2019-04-12 18:40 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-04-12 18:40:06 UTC


Attachments (Terms of Use)
anaconda.log (17.49 KB, text/plain)
2019-04-12 02:58 UTC, Geoffrey Marr
no flags Details
dbus.log (2.92 KB, text/plain)
2019-04-12 02:59 UTC, Geoffrey Marr
no flags Details
dnf.librepo.log (588 bytes, text/plain)
2019-04-12 02:59 UTC, Geoffrey Marr
no flags Details
lvm.log (199.43 KB, text/plain)
2019-04-12 03:00 UTC, Geoffrey Marr
no flags Details
packaging.log (5.10 KB, text/plain)
2019-04-12 03:00 UTC, Geoffrey Marr
no flags Details
program.log (48.93 KB, text/plain)
2019-04-12 03:01 UTC, Geoffrey Marr
no flags Details
sensitive-info.log (106 bytes, text/plain)
2019-04-12 03:01 UTC, Geoffrey Marr
no flags Details
storage.log (138.38 KB, text/plain)
2019-04-12 03:02 UTC, Geoffrey Marr
no flags Details
X.log (35.40 KB, text/plain)
2019-04-12 03:02 UTC, Geoffrey Marr
no flags Details

Description Geoffrey Marr 2019-04-12 02:57:25 UTC
Description of problem:
"Installation Source" shows an error upon starting up

Version-Release number of selected component (if applicable):
Fedora-Server-dvd-x86_64-30-20190405.n.0

How reproducible:
Always

Steps to Reproduce:
Attempt to install Fedora from an .iso stored on a separate partition using inst.repo. See this test: 

https://fedoraproject.org/wiki/QA:Testcase_install_repository_Hard_drive_variation

Actual results:
When the graphical installer starts up and shows the hub, the "Installation Source" shows the following: "Error setting up base repository".

Expected results:
Installer should automatically configure the "Installation Source" and show no error or require any user input on that spoke.

Additional info:
If the user clicks on the "Installation Source" spoke and then presses the "Done" button without making any changes, the source is configured and works like it should. 

See attached logs from /tmp for more info.

Comment 1 Geoffrey Marr 2019-04-12 02:58 UTC
Created attachment 1554693 [details]
anaconda.log

Comment 2 Geoffrey Marr 2019-04-12 02:59 UTC
Created attachment 1554694 [details]
dbus.log

Comment 3 Geoffrey Marr 2019-04-12 02:59 UTC
Created attachment 1554695 [details]
dnf.librepo.log

Comment 4 Geoffrey Marr 2019-04-12 03:00 UTC
Created attachment 1554696 [details]
lvm.log

Comment 5 Geoffrey Marr 2019-04-12 03:00 UTC
Created attachment 1554697 [details]
packaging.log

Comment 6 Geoffrey Marr 2019-04-12 03:01 UTC
Created attachment 1554698 [details]
program.log

Comment 7 Geoffrey Marr 2019-04-12 03:01 UTC
Created attachment 1554699 [details]
sensitive-info.log

Comment 8 Geoffrey Marr 2019-04-12 03:02 UTC
Created attachment 1554700 [details]
storage.log

Comment 9 Geoffrey Marr 2019-04-12 03:02 UTC
Created attachment 1554701 [details]
X.log

Comment 10 Fedora Blocker Bugs Application 2019-04-12 03:05:20 UTC
Proposed as a Blocker for 30-final by Fedora user coremodule using the blocker tracking app because:

 Proposing as a blocker as this violates the following F30 Final criteria [0]:

"The installer must be able to use all supported local and remote package and installer sources. "

[0] https://fedoraproject.org/wiki/Fedora_30_Final_Release_Criteria#Package_and_installer_sources

Comment 11 Jiri Konecny 2019-04-12 09:29:19 UTC
Hello, 

The compose Fedora-Server-dvd-x86_64-30-20190405.n.0 has an old Anaconda version without the NFS ISO fix. 

Please re-test this on a newer compose.

Comment 12 Jiri Konecny 2019-04-12 09:29:55 UTC
You probably experiencing the same issue as in bug 1691832.

Comment 13 Geoffrey Marr 2019-04-12 18:40:06 UTC
Jiri, thanks, it's fixed in the Fedora-Server-dvd-x86_64-30-20190411.n.0 compose! Will close the bug.


Note You need to log in before you can comment on or make changes to this bug.