Bug 1706482

Summary: [cloud-init][RHVM]cloud-init network configuration does not persist reboot [RHEL 8.2.0]
Product: Red Hat Enterprise Linux 8 Reporter: ldu <ldu>
Component: cloud-initAssignee: Eduardo Otubo <eterrell>
Status: CLOSED ERRATA QA Contact: Huijuan Zhao <huzhao>
Severity: high Docs Contact: Jiri Herrmann <jherrman>
Priority: high    
Version: 8.0CC: amashah, danken, eraviv, eterrell, fsun, huzhao, ikke, jcoscia, jgreguske, jherrman, jonathan.moore, ldu, linl, lmanasko, lrotenbe, lsurette, mkarg, mrezanin, pasik, ribarry, rmccabe, samuel.jon.gunnarsson, sirao, srevivo, sstagnar, vhutsky, vshypygu, yacao, yanjin, yujiang
Target Milestone: rc   
Target Release: 8.2   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: cloud-init-18.5-8.el8 Doc Type: Known Issue
Doc Text:
(See https://bugzilla.redhat.com/show_bug.cgi?id=1666961 )
Story Points: ---
Clone Of: 1593010 Environment:
Last Closed: 2020-04-28 16:03:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1593010, 1750710    
Bug Blocks:    

Comment 5 Yaju Cao 2019-07-10 09:33:40 UTC
Remove needinfo in comment 3 since it has already been tested in https://bugzilla.redhat.com/show_bug.cgi?id=1593010#c74, and the issue still exist, so we need to continue working on the fix.

Comment 13 Huijuan Zhao 2020-02-19 03:46:52 UTC
Tested with cloud-init-18.5-10.el8 on RHV, the issue is gone.

Verified on:
- RHV 4.3.4.3-0.1.el7
- libvirt-3.9.0-14.el7.x86_64
- VM: RHEL8.0 + cloud-init-18.5-10.el8

Verification steps:
1. Create VM with RHEL 8.0 (register to rhsm, enable baseos/appstream repos)
2. Install cloud-init cloud-init-18.5-10.el8
3. Start the service and set it up permanently by 'systemctl enable --now cloud-init'.
4. Power off the vm and create template.
5. Create a new vm from the new template with the following cloud init parameters (by GUI): 'TZ: +13 Tonga, Network: static, NIC Name: eth0, IP: 10.0.0.1, MASK: 255.255.255.0, GW: 10.0.0.254'.
6. Start the vm and verify cloud-init parameters are as expected (by `ip a` and  `cat /etc/sysconfig/network-scripts/ifcfg-eth0`).
7. Power off the vm from engine and repeat step 6.

Result:

- Cloud-init parameters was remain as expected after vm is powered off and restarted.


Move the status to VERIFIED.

Comment 15 errata-xmlrpc 2020-04-28 16:03:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1719