Bug 1707477

Summary: No way to grant access to router via NetworkPolicy
Product: OpenShift Container Platform Reporter: Casey Callendrello <cdc>
Component: NetworkingAssignee: Casey Callendrello <cdc>
Status: CLOSED ERRATA QA Contact: Meng Bo <bmeng>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 4.1.0CC: aos-bugs, zzhao
Target Milestone: ---   
Target Release: 4.1.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-04 10:48:34 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Casey Callendrello 2019-05-07 15:25:07 UTC
Problem:
The openshift-ingress namespace has no labels, so there's no way to select for it with namespaces.

Nor can you grant access to prometheus.

Comment 3 zhaozhanqi 2019-05-08 07:04:38 UTC
Verified this bug 4.1.0-0.nightly-2019-05-07-233329

oc get namespaces openshift-ingress --show-labels
NAME                STATUS   AGE     LABELS
openshift-ingress   Active   3h24m   name=openshift-ingress,network.openshift.io/policy-group=ingress,openshift.io/cluster-monitoring=true

Comment 5 errata-xmlrpc 2019-06-04 10:48:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758