Bug 4 - Installer fails on LILO step
Installer fails on LILO step
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
5.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-06 18:36 EST by alan
Modified: 2009-08-06 10:37 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 11:16:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alan 1998-11-06 18:36:27 EST
Create 3 DOS partitions the add Linux in some other partitions
The installer puts all the DOS partitions in lilo.conf,
lilo realises some arent bootable and bales out - whoops
Comment 1 David Lawrence 1998-11-12 12:53:59 EST
Created three dos partitions of 200 MB size. One primary and one extended with
two logical. Marked only the primary as bootable and installed Linux to the free
space on the drive. Lilo step functioned properly. Tried again except toggled
all dos partitions bootable. Again it worked properly and only showed the
primary dos partition and the linux root in the lilo list of possible choices.
I guess it could be caused by some third party boot loader being previously
installed or NT.Created three dos partitions of 200 MB size. One primary and one extended with
two logical. Marked only the primary as bootable and installed Linux to the free
space on the drive. Lilo step functioned properly. Tried again except toggled
all dos partitions bootable. Again it worked properly and only showed the
primary dos partition and the linux root in the lilo list of possible choices.
I guess it could be caused by some third party boot loader being previously
installed or NT.
Comment 2 Need Real Name 1998-11-12 13:29:59 EST
From Alan (see mail link):

Not on this disk. It was an install from disk partiton -> disk
partition with the files copied off the RH gold CD. If you can't
reproduce it I'll have another go.
Comment 3 vic2000 1998-11-19 15:27:59 EST
I had and still have the exact same problem. I have a
multi-partitioned HDD. I used to have NT4 (not any more), but 5.2, did
the same, put all DOS partitions (5 of them) in lilo.conf. It realised
something was wrong and reported an error.
The installation was from a vfat hard drive. I should also mention
that I had installed 5.1 the same way and no problems occured, even
though I was using the NT bootloader and the little utility called
bootpart, to boot 5.1.
Comment 4 vic2000 1998-11-19 15:29:59 EST
The only apparent solution, for users experiencing this fault, is to
make sure that they make a boot disk. You boot off of it and edit
lilo.conf (deleting the extra partitions)and then run lilo.
Comment 5 David Lawrence 1998-11-20 10:28:59 EST
You can also just remove the extra choices in the lilo configuration
at the end of the install byt highlighting the extras and choosing
edit where you can delete the extra labels. This will make the
installer write a lilo.conf with only the labels you leave. Strangely
I feel something else is at fault because even with all the extra
choices you should still be able to type linux at the lilo prompt and
boot up Linux. Have you tried running the dos fdisk program with the
/mbr switch to clear out the MBR completely before installing? See if
that has any effect.
Comment 6 Anonymous 1998-11-26 21:00:59 EST
The same problem here. If I correctly remember, there were only two
bootable partitions listed at the end of my install. It was my
assumption that the display can handle up to four partitions without
scrolling (I haven't tried wether I need to scroll down in order to
display more than two). Anyway, four partitions (including one logical
drive) went into lilo.conf (named "linux", and three times "dos" I
think) which caused an error. Using the custom boot disk and cutting
lilo.conf was the cure.
Comment 7 David Lawrence 1998-11-30 13:09:59 EST
This bug has been passed on to a developer for further review.
Comment 8 scotts 1998-12-17 22:23:59 EST
I had the same problem, specifially with 4 Mb machines (the others,
32 Mb plus) were fine. I read on usenet that it was a 4 Mb problem,
higher MB machines have no problem.. apparently.
Comment 9 kenneth_porter 1999-01-16 00:40:59 EST
When configuring LILO during install, I specified an alternate
partition name of "UtilitiesPartition". The installer wrote this to
lilo.conf and reported that it couldn't install LILO in the MBR.
After I RTFM, I am able to diagnose the problem with "lilo -t -v" and
am able to correct the problem.

It seems that the fundamental problem is that the installer is
producing invalid lilo.conf files and is not adequately validating
the user's arguments. Related bugs showing variations on this problem
are 44, 51, 204, and 227.

I recommend that the installer's lilo.conf-writer be revisited, and
that when retrying the lilo operation, it be run in verbose mode with
the results displayed to the user. At minimum the verbose error
messages should be displayed on the error console.
Comment 10 Preston Brown 1999-03-18 09:39:59 EST
Matt have you fixed this in the latest installer?  If so please close
the bug.
Comment 11 Jay Turner 1999-07-07 12:44:59 EDT
*** Bug 3486 has been marked as a duplicate of this bug. ***

make all new partition table, including linux (type=83),
swap (type=82), a vfat (type=c) partition.  When lilo tries
to install the bootloader in the MBR (/dev/hda, NOT
/dev/hda1), it fails, probably because the DOS partition has
not yet been formatted.  Clearing the partition from the
list of partitions to mount/boot with lilo permits the
install to continue, otherwise you're stuck.


------- Additional Comments From jturner@redhat.com  06/16/99 15:09 -------
We are aware of this issue and are going to provide better wording in
future releases in order to prevent this type of thing.
Comment 12 Bill Nottingham 1999-09-24 23:47:59 EDT
*** Bug 1742 has been marked as a duplicate of this bug. ***

If you "make" a msdos partition with diskdruid during
installation, lilo will fail to install. This is because the
device does not have a valid filesystem. I reported this to
dale before beta testing for 5.6.x+ when I found it while
installing RH 5.2, he said that if it appeared in the beta's
to let you know. So now I am.

------- Additional Comments From pbrown@redhat.com  03/26/99 16:33 -------
this one looks nasty Matt.

------- Additional Comments From msw@redhat.com  04/01/99 00:51 -------


*** Bug 1334 has been marked as a duplicate of this bug. ***

Lilo warnings are not shown to the user if they occur during
installation.  As some lilo warnings indicate a serious
problem you can easily get caught out and lock up your
machine.

------- Additional Comments From gafton@redhat.com  03/18/99 19:40 -------
assigned to msw

------- Additional Comments From msw@redhat.com  04/01/99 00:58 -------


*** Bug 1451 has been marked as a duplicate of this bug. ***

At the end of the install for 5.2 the user is asked where
lilo should be installed.  I selected Master Boot Record.
The write of the loader to the Boot Record failed.  I tried
and tried to install lilo via the normal install.
Eventually I found that the installer had written a
lilo.conf file that was too big to be written to the
boot sector.  So I removed some entries and then ran lilo.
I would think that a safeguard would be in place to
keep lilo.conf from growing to be too big.

------- Additional Comments From msw@redhat.com  04/01/99 00:57 -------
it's not that the lilo entries were too big - it's probably that there
was an entry for "dos" in the lilo configuration pointing at a dos
filesystem that didn't have a valid boot block on it.
Comment 13 Matt Wilson 1999-12-22 12:27:59 EST
Please verify against 6.1.
Comment 14 Riley H Williams 1999-12-23 12:51:59 EST
I've only just noticed this bug report, but I can confirm that it is the case
with the official RedHat 6.1 as available on ftp.redhat.com online. This appears
to be due to an unwarranted assumption during the install, namely that any
partitions for other operating systems than Linux have already had the relevant
operating system installed.

There are two related solutions to this that I can see:

 1. Include a line saying "optional" in the global section of
    /etc/lilo.conf

 2. Include a line saying "optional" in each non-Linux section
    of /etc/lilo.conf

Either should fix the problem.
Comment 15 IBM Bug Proxy 2004-06-02 17:24:04 EDT
----- Additional Comments From chavez@us.ibm.com(prefers email via lnx1138@us.ibm.com)  2004-06-02 17:01 -------
Glen,

Please mirror this to Redhat. 
Comment 16 IBM Bug Proxy 2004-07-01 13:19:11 EDT
----- Additional Comments From thinh@us.ibm.com  2004-07-01 13:14 -------
Glen, Please mirror to RedHat. Thanks. 
Comment 17 IBM Bug Proxy 2004-07-14 15:17:01 EDT
----- Additional Comments From thinh@us.ibm.com  2004-07-14 15:12 -------
Glen/Stacy, please mirror to RedHat. Thanks. 
Comment 18 IBM Bug Proxy 2004-07-14 15:17:21 EDT
----- Additional Comments From thinh@us.ibm.com  2004-07-14 15:15 -------
Glen/Stacy, Please mirror to RedHat. Thanks. 
Comment 19 IBM Bug Proxy 2004-07-14 15:17:41 EDT
----- Additional Comments From thinh@us.ibm.com  2004-07-14 15:17 -------
Glen/Stacy, Please mirror to RedHat. Thanks. 
Comment 20 Alan Cox 2004-07-14 17:48:34 EDT
IBM folks can you please fix whatever broken tool keeps appending
stuff to this ancient RH 5.2 bug. 
Comment 21 sudhakar_nke 2008-08-07 07:55:42 EDT
*** Bug 458256 has been marked as a duplicate of this bug. ***
Comment 22 Chris Lumens 2009-08-06 10:37:09 EDT
*** Bug 516041 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.