Bug 1707552

Summary: conflicts with yum-plugin-changelog
Product: [Fedora] Fedora Reporter: josef radinger <cheese>
Component: dnf-plugins-coreAssignee: Marek Blaha <mblaha>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: bugzilla, dmach, jmracek, mblaha, packaging-team-maint, pkratoch, praiskup, rpm-software-management, vmukhame
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: dnf-plugins-core-4.0.9-1.fc30 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-06 12:31:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description josef radinger 2019-05-07 18:44:00 UTC
Description of problem:

upgrade from f29 to f30:
dnf --releasever=30 --setopt=deltarpm=false distro-sync --allowerasing

...
[SKIPPED] wolf4sdl-spear-demo-1.7-9.fc30.x86_64.rpm: Already downloaded                                                                                                                                                                                               
[SKIPPED] xv-3.10a.jumbopatch.20070520-31.fc30.x86_64.rpm: Already downloaded                                                                                                                                                                                         
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/man/man1/yum-changelog.1.gz conflicts between attempted installs of yum-plugin-changelog-1.1.31-519.fc30.noarch and dnf-plugins-core-4.0.6-1.fc30.noarch
  file /usr/share/man/man5/yum-changelog.conf.5.gz conflicts between attempted installs of yum-plugin-changelog-1.1.31-519.fc30.noarch and dnf-plugins-core-4.0.6-1.fc30.noarch

Error Summary
-------------

Comment 1 Marek Blaha 2019-05-09 05:12:30 UTC
PR https://github.com/rpm-software-management/dnf-plugins-core/pull/333 fixes the issue.

Comment 2 Fedora Update System 2019-08-14 12:11:13 UTC
FEDORA-2019-40235845dc has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-40235845dc

Comment 3 Fedora Update System 2019-08-16 19:50:20 UTC
dnf-4.2.8-1.fc30, dnf-plugins-core-4.0.9-1.fc30, dnf-plugins-extras-4.0.5-1.fc30, libdnf-0.35.2-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-40235845dc

Comment 4 Fedora Update System 2019-08-26 13:26:27 UTC
FEDORA-2019-40235845dc has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-40235845dc

Comment 5 Fedora Update System 2019-08-27 18:21:25 UTC
dnf-4.2.8-1.fc30, dnf-plugins-core-4.0.9-1.fc30, dnf-plugins-extras-4.0.5-1.fc30, libdnf-0.35.2-1.fc30, swid-tools-0.8.6-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-40235845dc

Comment 6 Fedora Update System 2019-08-29 05:05:22 UTC
FEDORA-2019-40235845dc has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-40235845dc

Comment 7 Fedora Update System 2019-08-30 00:03:36 UTC
dnf-4.2.8-1.fc30, dnf-plugins-core-4.0.9-1.fc30, libdnf-0.35.2-1.fc30, swid-tools-0.8.6-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-40235845dc

Comment 8 Michal Domonkos 2019-09-05 14:53:47 UTC
*** Bug 1722838 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2019-09-06 12:31:00 UTC
dnf-4.2.8-1.fc30, dnf-plugins-core-4.0.9-1.fc30, libdnf-0.35.2-1.fc30, swid-tools-0.8.6-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.