Bug 1722838 - Update from Fedora 29 to Fedora 30 fails, because of package conflict.
Summary: Update from Fedora 29 to Fedora 30 fails, because of package conflict.
Keywords:
Status: CLOSED DUPLICATE of bug 1707552
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Domonkos
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-21 13:00 UTC by Frank Büttner
Modified: 2019-09-05 14:53 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-05 14:53:47 UTC


Attachments (Terms of Use)

Description Frank Büttner 2019-06-21 13:00:58 UTC
Description of problem:
The file /usr/share/man/man1/yum-changelog.1.gz and /usr/share/man/man5/yum-changelog.conf.5.gz are listed in two packages, so the upgrade fails.

Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/man/man1/yum-changelog.1.gz conflicts between attempted installs of yum-plugin-changelog-1.1.31-519.fc30.noarch and dnf-plugins-core-4.0.7-1.fc30.noarch
  file /usr/share/man/man5/yum-changelog.conf.5.gz conflicts between attempted installs of yum-plugin-changelog-1.1.31-519.fc30.noarch and dnf-plugins-core-4.0.7-1.fc30.noarch

Error Summary

Comment 1 Cezary Zemis 2019-07-12 07:43:53 UTC
Workaround is obvious: to remove yum-plugin-changelog before upgrading.

Comment 2 Michal Domonkos 2019-09-05 14:29:13 UTC
Fixed upstream:
https://github.com/rpm-software-management/dnf-plugins-core/pull/355

Comment 3 Michal Domonkos 2019-09-05 14:53:47 UTC
Turns out the above PR is not needed anymore thanks to the bug 1707552 fix.

*** This bug has been marked as a duplicate of bug 1707552 ***


Note You need to log in before you can comment on or make changes to this bug.