Bug 171

Summary: upgrade from 5.1 to 5.2 segmentation faults
Product: [Retired] Red Hat Linux Reporter: happy
Component: installerAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1998-11-24 20:42:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description happy 1998-11-23 15:00:48 UTC
When I try to upgrade from 5.1 to 5.2, the installer exits
with signal 11.  I don't think I am having hardware problems
since everything else works fine and memtest says my memory
is fine.

This is on a Dell Optiplex GXpro with an Adaptec 2940 card.

I've mostly tried installing via CD but have similar
problems doing an FTP install.

Comment 1 happy 1998-11-24 20:12:59 UTC
OK, I'm an idiot.  I had /var/tmp symlinked somewhere that no longer
existed.  I thought I fixed this but I must not have umount'd the fs
after fixing it.  I fixed it for good and everything is fine again.

It would be nice if the install didn't syssegv but ... I bet you don't
have so many idiots :)

PS:  /var is now in a very large partition and I won't have to symlink
ever again, I swear :)

Comment 2 David Lawrence 1998-11-24 20:42:59 UTC
/var/tmp is a critical directory that must be present for the install
to work poperly. We hope to account for things like this inthe future
but fo rnow this is the way it must be.