Bug 1711863

Summary: [UPDATE] Compute update failed with "RuntimeError('Update failed with: {}'.format(payload['message']))"
Product: Red Hat OpenStack Reporter: Raviv Bar-Tal <rbartal>
Component: openstack-tripleo-heat-templatesAssignee: mbollo
Status: CLOSED ERRATA QA Contact: Raviv Bar-Tal <rbartal>
Severity: high Docs Contact:
Priority: high    
Version: 15.0 (Stein)CC: atonner, dbecker, jschluet, lbezdick, mbollo, mbultel, mburns, michele, morazi, sathlang, sclewis, slinaber
Target Milestone: rcKeywords: Triaged
Target Release: 15.0 (Stein)Flags: mbollo: needinfo+
mbollo: needinfo+
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-10.6.1-0.20190814130506.e018bab.el8ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-21 11:22:06 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1727808    
Attachments:
Description Flags
compute update log none

Description Raviv Bar-Tal 2019-05-20 09:32:29 UTC
Created attachment 1571250 [details]
compute update log

Description of problem:
Compute update failed with Trackback (see full log attached):

Ansible failed, check log at /var/lib/mistral/fcfa315b-c233-47fa-bc03-59260c96bade/ansible.log.
2019-05-20 04:51:42.338 523239 ERROR tripleoclient.v1.overcloud_update.MinorUpdateRun [-] Exception occured while running the command: RuntimeError: Update failed with: Ansi
ble failed, check log at /var/lib/mistral/fcfa315b-c233-47fa-bc03-59260c96bade/ansible.log.
2019-05-20 04:51:42.338 523239 ERROR tripleoclient.v1.overcloud_update.MinorUpdateRun Traceback (most recent call last):
2019-05-20 04:51:42.338 523239 ERROR tripleoclient.v1.overcloud_update.MinorUpdateRun   File "/usr/lib/python3.6/site-packages/tripleoclient/command.py", line 32, in run
2019-05-20 04:51:42.338 523239 ERROR tripleoclient.v1.overcloud_update.MinorUpdateRun     super(Command, self).run(parsed_args)
2019-05-20 04:51:42.338 523239 ERROR tripleoclient.v1.overcloud_update.MinorUpdateRun   File "/usr/lib/python3.6/site-packages/osc_lib/command/command.py", line 41, in run
2019-05-20 04:51:42.338 523239 ERROR tripleoclient.v1.overcloud_update.MinorUpdateRun     return super(Command, self).run(parsed_args)
2019-05-20 04:51:42.338 523239 ERROR tripleoclient.v1.overcloud_update.MinorUpdateRun   File "/usr/lib/python3.6/site-packages/cliff/command.py", line 184, in run
2019-05-20 04:51:42.338 523239 ERROR tripleoclient.v1.overcloud_update.MinorUpdateRun     return_code = self.take_action(parsed_args) or 0
2019-05-20 04:51:42.338 523239 ERROR tripleoclient.v1.overcloud_update.MinorUpdateRun   File "/usr/lib/python3.6/site-packages/tripleoclient/v1/overcloud_update.py", line 18
0, in take_action
2019-05-20 04:51:42.338 523239 ERROR tripleoclient.v1.overcloud_update.MinorUpdateRun     verbosity=verbosity)
2019-05-20 04:51:42.338 523239 ERROR tripleoclient.v1.overcloud_update.MinorUpdateRun   File "/usr/lib/python3.6/site-packages/tripleoclient/utils.py", line 1056, in run_upd
ate_ansible_action
2019-05-20 04:51:42.338 523239 ERROR tripleoclient.v1.overcloud_update.MinorUpdateRun     extra_vars=extra_vars)
2019-05-20 04:51:42.338 523239 ERROR tripleoclient.v1.overcloud_update.MinorUpdateRun   File "/usr/lib/python3.6/site-packages/tripleoclient/workflows/package_update.py", li
ne 105, in update_ansible
2019-05-20 04:51:42.338 523239 ERROR tripleoclient.v1.overcloud_update.MinorUpdateRun     raise RuntimeError('Update failed with: {}'.format(payload['message']))
2019-05-20 04:51:42.338 523239 ERROR tripleoclient.v1.overcloud_update.MinorUpdateRun RuntimeError: Update failed with: Ansible failed, check log at /var/lib/mistral/fcfa315
b-c233-47fa-bc03-59260c96bade/ansible.log.
2019-05-20 04:51:42.338 523239 ERROR tripleoclient.v1.overcloud_update.MinorUpdateRun 
2019-05-20 04:51:42.341 523239 ERROR openstack [-] Update failed with: Ansible failed, check log at /var/lib/mistral/fcfa315b-c233-47fa-bc03-59260c96bade/ansible.log.: Runti
meError: Update failed with: Ansible failed, check log at /var/lib/mistral/fcfa315b-c233-47fa-bc03-59260c96bade/ansible.log.
2019-05-20 04:51:42.341 523239 INFO osc_lib.shell [-] END return value: 1

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install osp15
2.update undercloud, update Controllers 
3. update computes 'openstack overcloud update run --stack overcloud --roles Compute --playbook all'


Actual results:


Expected results:


Additional info:

Comment 1 Raviv Bar-Tal 2019-07-22 13:31:54 UTC
Hey Mathieu
Do we have any progress on this BZ?
Are we going to get a fix for it?

Comment 6 Sofer Athlan-Guyot 2019-08-19 13:06:24 UTC
*** Bug 1741380 has been marked as a duplicate of this bug. ***

Comment 13 errata-xmlrpc 2019-09-21 11:22:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811