Bug 1731706

Summary: dsniff depends on files/directories from non-standard locations
Product: [Fedora] Fedora Reporter: Igor Gnatenko <i.gnatenko.brain>
Component: dsniffAssignee: Robert Scheck <redhat-bugzilla>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: redhat-bugzilla
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: dsniff-2.4-0.29.b1.fc31 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-07-22 21:26:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1731683    

Description Igor Gnatenko 2019-07-21 11:11:26 UTC
Hello,

Fedora Packaging Guidelines allow dependencies only on files/directories from /usr/bin, /usr/sbin and /etc directories[0].
Your package depends on files/directories outside of those. See below for more information about package/dependencies.

---
dsniff-2.4-0.29.b1.fc30.src:
  - /usr/include/pcap.h
---

Please correct those or provide reason why is it correct.
It is very important to not download huge filelists.xml just because few packages in distribution depend on non-standard paths.

Thanks for cooperation!


[0] https://docs.fedoraproject.org/en-US/packaging-guidelines/#_file_and_directory_dependencies

Comment 1 Robert Scheck 2019-07-22 21:26:04 UTC
Given you highlighted a BuildRequires, the argumentation regarding filelists.xml is questionable. Changed nevertheless, given it's a relict.