Bug 1731717

Summary: mkdocs depends on files/directories from non-standard locations
Product: [Fedora] Fedora Reporter: Igor Gnatenko <i.gnatenko.brain>
Component: mkdocsAssignee: Orphan Owner <extras-orphan>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 31CC: extras-orphan, williamjmorenor
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: mkdocs-1.1-4.fc32 mkdocs-1.1-4.fc31 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-22 11:30:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1731683    

Description Igor Gnatenko 2019-07-21 11:11:44 UTC
Hello,

Fedora Packaging Guidelines allow dependencies only on files/directories from /usr/bin, /usr/sbin and /etc directories[0].
Your package depends on files/directories outside of those. See below for more information about package/dependencies.

---
mkdocs-0.16.3-9.fc30.src:
  - /usr/share/javascript/jquery/1.12.4/jquery.min.js
  - /usr/share/javascript/highlight.js/highlight.pack.js
  - /usr/share/fonts/fontawesome/fontawesome-webfont.woff
  - /usr/share/fonts/fontawesome/fontawesome-webfont.svg
  - /usr/share/javascript/jquery/3.2.1/jquery.min.js
  - /usr/share/fonts/fontawesome/fontawesome-webfont.ttf
  - /usr/share/fonts/fontawesome/FontAwesome.otf
---

Please correct those or provide reason why is it correct.
It is very important to not download huge filelists.xml just because few packages in distribution depend on non-standard paths.

Thanks for cooperation!


[0] https://docs.fedoraproject.org/en-US/packaging-guidelines/#_file_and_directory_dependencies

Comment 1 Ben Cotton 2019-08-13 17:00:40 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 2 Ben Cotton 2019-08-13 18:57:14 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 3 Miro HronĨok 2019-09-22 11:30:13 UTC
Automation has figured out the package is retired in Fedora 31.

If you like it to be unretired, please open a ticket at https://pagure.io/releng/new_issue?template=package_unretirement

Comment 4 Fedora Update System 2020-03-27 14:54:25 UTC
FEDORA-2020-505423242a has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-505423242a

Comment 5 Fedora Update System 2020-03-27 14:54:28 UTC
FEDORA-2020-c75b5fcaaf has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-c75b5fcaaf

Comment 6 Fedora Update System 2020-03-28 02:43:05 UTC
FEDORA-2020-505423242a has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf install --enablerepo=updates-testing --advisory=FEDORA-2020-505423242a \*`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-505423242a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2020-03-28 14:59:19 UTC
FEDORA-2020-c75b5fcaaf has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf install --enablerepo=updates-testing --advisory=FEDORA-2020-c75b5fcaaf \*`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-c75b5fcaaf

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2020-04-05 00:15:49 UTC
FEDORA-2020-c75b5fcaaf has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2020-04-05 03:03:34 UTC
FEDORA-2020-505423242a has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.