Bug 173414

Summary: DISPLAY not set for ssh -Y session
Product: [Fedora] Fedora Reporter: John Ellson <john.ellson>
Component: opensshAssignee: Tomas Mraz <tmraz>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: high    
Version: rawhideCC: oliva, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-11-23 02:28:01 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description John Ellson 2005-11-16 19:26:16 EST
Description of problem:
After installing today's modular X rpms, "ssh -Y remote" no longer sets DISPLAY
on the remote system such that remote gui applications no longer work.

reverting back to 6.8.2 fixes the problem

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-0.99.3-5

How reproducible:
100%

Steps to Reproduce:
1.ssh -Y remote
2.xterm
3.
  
Actual results:
xterm Xt error: Can't open display:
xterm:  DISPLAY is not set


Expected results:
support remote gui applications

Additional info:
Comment 1 Bill Crawford 2005-11-16 22:09:13 EST
This would be due to the change in location of "xauth"
Comment 2 Mike A. Harris 2005-11-17 02:09:04 EST
Reassigning to the openssh component, to have ssh updated to invoke xauth
from /usr/bin/xauth.  I also recommend having it fall back to checking
/usr/X11R6/bin/xauth if the binary is not found in /usr/bin however, or
alternatively using the system PATH to locate the binary.
Comment 3 Warren Togami 2005-11-18 11:01:48 EST
I was almost successful in fixing this yesterday, but openssh rebuild is failing
because gccmakedep is missing from modular X packages.  So this is blocking on
mharris at the moment.


*** This bug has been marked as a duplicate of 173568 ***
Comment 4 Alexandre Oliva 2005-11-18 12:37:35 EST
This not a dupe, just a regular dependency.  
Comment 5 Mike A. Harris 2005-11-21 02:58:42 EST
(In reply to comment #3)
> I was almost successful in fixing this yesterday, but openssh rebuild is failing
> because gccmakedep is missing from modular X packages.  So this is blocking on
> mharris at the moment.

To be clear - this is blocking on X.Org at the moment.  There is no gccmakedep
in modular X at this time.  Once X.Org has gccmakedep available in the modular
X tree, it will get added to our packages.

Hope this clarifies any confusion.
Comment 6 Tomas Mraz 2005-11-21 04:39:39 EST
I'm not sure we really need the gccmakedep at all - I think that the
ssh-askpass-x11 should be dropped from the build completely as the
ssh-askpass-gnome is good enough and it regardless of its name doesn't depend on
complete gnome environment - only GTK+-2. I will modify openssh so only the
gnome askpass is built. If for some reason someone really needs the x11 askpass,
he can  package it in Extras.
Comment 7 Mike A. Harris 2005-11-21 14:19:00 EST
gccmakedep will probably be in X11R7 RC3, which is scheduled for Nov 30.
There is a patch in CVS right now to add it to the modular tree, but there
wont be tarballs until later.  Just thought I'd mention this so everyone's
aware of the status.

Comment 8 Tomas Mraz 2005-11-23 02:28:01 EST
Openssh does no longer contain the x11-ssh-askpass and so it doesn't require
imake and gccmakedep.

Also the original bug should be already resolved by rebuild.