Bug 173568 - gccmakedep is missing, breaks openssh build
Summary: gccmakedep is missing, breaks openssh build
Status: CLOSED DUPLICATE of bug 173478
Alias: None
Product: Fedora
Classification: Fedora
Component: imake   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 171491 FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2005-11-18 04:33 UTC by Warren Togami
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-23 03:55:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Warren Togami 2005-11-18 04:33:19 UTC
Rebuilding openssh in FC5 fails at:

gccmakedep  --   -I/usr/X11R6/include    -Dlinux -D__amd64__
-D_POSIX_C_SOURCE=199309L                          -D_POSIX_SOURCE
-D_XOPEN_SOURCE                              -D_BSD_SOURCE -D_SVID_SOURCE      
                          -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64           
                                                    -DFUNCPROTO=15 -DNARROWPROTO
     -- drawing.c dynlist.c resources.c x11-ssh-askpass.c
/bin/sh: gccmakedep: command not found

Searching around all spec files and repodata, I see no mention of gccmakedep
anywhere.  Is this a mistake that it is not included in modular X?

Comment 1 Warren Togami 2005-11-18 04:43:50 UTC
I was trying to rebuild openssh before test1 in order it to pick up the new
xauth location so X forwarding would work with modular X.

http://cvs.fedora.redhat.com/viewcvs/devel/openssh/
I have checked in other spec fixes necessary for building this on rawhide with
modular X.  I am stuck on the missing gccmakedep.


Comment 2 Warren Togami 2005-11-18 16:02:04 UTC
*** Bug 173414 has been marked as a duplicate of this bug. ***

Comment 3 Mike A. Harris 2005-11-21 07:56:29 UTC
Please file a bug in X.Org bugzilla indicating that "gccmakedep" does not
exist in the modular X release, however it is required.  Mark the bug
as blocking bug #1690, and paste the URL here.  Once a tarball becomes
available, it will be added to our "imake" package.



Comment 4 Mike A. Harris 2005-11-23 03:55:30 UTC

*** This bug has been marked as a duplicate of 173478 ***


Note You need to log in before you can comment on or make changes to this bug.