Bug 1738362

Summary: systemd-243~rc1-1.fc31 no longer provides /etc/systemd/system
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: systemdAssignee: systemd-maint
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: rawhideCC: dtardon, lnykryn, msekleta, robatino, ssahani, s, systemd-maint, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: openqa
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-08-07 07:29:11 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1644937    

Description Adam Williamson 2019-08-07 00:21:48 UTC
For some reason - it's a bit obscure because of the split-files.py script which I am not going to attempt to understand - systemd-243~rc1-1.fc31 does not provide /etc/systemd/system , while systemd-242-7.git9d34e79.fc31 and earlier versions did.

This is a major problem because freeipa-server "Requires: /etc/systemd/system", and is consequently now not installable in Rawhide, which violates the release criteria:

"It must be possible to configure a Fedora Server system installed according to the above criteria as a FreeIPA domain controller, using the official deployment tools provided in the distribution FreeIPA packages..." - https://fedoraproject.org/wiki/Basic_Release_Criteria#FreeIPA_server_requirements

Comment 1 David Tardon 2019-08-07 07:29:11 UTC

*** This bug has been marked as a duplicate of bug 1737362 ***