Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1737362 - file /etc/systemd/system is not owned by any package
Summary: file /etc/systemd/system is not owned by any package
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1737638 1738362 (view as bug list)
Depends On:
Blocks: F31BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2019-08-05 08:37 UTC by Lukas Slebodnik
Modified: 2019-08-07 15:48 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-07 15:48:57 UTC
Type: Bug


Attachments (Terms of Use)

Description Lukas Slebodnik 2019-08-05 08:37:36 UTC
Description of problem:
The recent upgrade of systemd broke some packages which requires the directory /etc/systemd/system

Version-Release number of selected component (if applicable):
rpm -q systemd
systemd-243~rc1-1.fc31.x86_64

How reproducible:
Deterministic

Steps to Reproduce:
1. dnf repoquery --whatprovides /etc/systemd/system

Actual results:
sh# dnf repoquery --whatprovides /etc/systemd/system
Last metadata expiration check: 0:01:29 ago on Mon 05 Aug 2019 10:32:07 AM CEST.

sh# echo $?
0

Expected results:
//the same as on fedora 30
sh# dnf repoquery --whatprovides /etc/systemd/system
Last metadata expiration check: 0:00:39 ago on Mon Aug  5 08:35:27 2019.
systemd-0:241-10.git511646b.fc30.i686
systemd-0:241-10.git511646b.fc30.x86_64
systemd-0:241-7.gita2eaa1c.fc30.i686
systemd-0:241-7.gita2eaa1c.fc30.x86_64


Additional info:

If it was an intentional change then BZ should be moved to problematic packages which requires that directory

sh# dnf repoquery --whatrequires /etc/systemd/system
Last metadata expiration check: 0:05:05 ago on Mon 05 Aug 2019 10:32:07 AM CEST.
freeipa-server-0:4.8.0-2.fc31.x86_64

Comment 1 Zbigniew Jędrzejewski-Szmek 2019-08-05 12:25:11 UTC
Oops, I removed all files in /etc from the package, and forgot to re-add the directory. Will fix.

Comment 2 Zbigniew Jędrzejewski-Szmek 2019-08-05 13:05:00 UTC
https://github.com/systemd/systemd/pull/13267

Comment 3 Zbigniew Jędrzejewski-Szmek 2019-08-06 14:08:34 UTC
*** Bug 1737638 has been marked as a duplicate of this bug. ***

Comment 4 David Tardon 2019-08-07 07:29:11 UTC
*** Bug 1738362 has been marked as a duplicate of this bug. ***

Comment 5 Lukas Slebodnik 2019-08-07 07:54:45 UTC
(In reply to Zbigniew Jędrzejewski-Szmek from comment #2)
> https://github.com/systemd/systemd/pull/13267

I can see it is already merged in upstream.

Would you mind to backport the patch to rawhide ?

Comment 6 Adam Williamson 2019-08-07 15:48:57 UTC
I've done it: https://koji.fedoraproject.org/koji/buildinfo?buildID=1348783

so this should be fixed in the next compose.


Note You need to log in before you can comment on or make changes to this bug.