Bug 1744266

Summary: Fedora 31 still using Fedora 30 backgrounds
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: desktop-backgroundsAssignee: Martin Sourada <martin.sourada>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 31CC: caillon+fedoraproject, caolanm, cwickert, dingyichen, gmarr, gnome-sig, john.j5live, kevin, luya_tfz, martin.sourada, mclasen, rdieter, rhughes, robatino, rstrode, sandmann
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: openqa AcceptedBlocker
Fixed In Version: desktop-backgrounds-31.0.0-1.fc31 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-12 17:09:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1745846, 1749086    
Bug Blocks: 1644937    

Description Adam Williamson 2019-08-21 16:50:52 UTC
As of right now, Fedora 31 still uses Fedora 30 backgrounds (on all desktops, including GNOME and KDE). This is a violation of Basic criterion "The default desktop background must be different from that of the last two stable releases" - https://fedoraproject.org/wiki/Basic_Release_Criteria#Desktop_background .

The usual stuff needs doing to fix this: an f31-backgrounds needs to be packaged and reviewed, the desktop-backgrounds subpackages all need updating to point to it, and kde-settings needs updating.

Comment 1 Luya Tshimbalanga 2019-08-21 23:13:58 UTC
Design Team has a Github for the Fedora 31 backgrounds located on https://github.com/fedoradesign/backgrounds. It include the updated spec file ready for review
The default wallpaper is currently under the work for beta release along with the animated version. Once packaged, I will assign this report as a blocker for the review process.

Comment 2 Geoffrey Marr 2019-08-26 15:55:18 UTC
+1 blocker

Comment 3 Geoffrey Marr 2019-08-26 18:09:04 UTC
Discussed during the 2019-08-26 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedBlocker" was made as it violates the following criteria:

"The default desktop background must be different from that of the last two stable releases."

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-08-26/f31-blocker-review.2019-08-26-16.00.txt

Comment 4 Fedora Update System 2019-09-04 03:44:06 UTC
FEDORA-2019-8b2cccfabf has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-8b2cccfabf

Comment 5 Fedora Update System 2019-09-04 10:51:39 UTC
desktop-backgrounds-31.0.0-1.fc31, f31-backgrounds-31.0.2-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-8b2cccfabf

Comment 6 Adam Williamson 2019-09-04 20:29:12 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1749086 is the bug for updating KDE packages. The update in #c5 will fix GNOME and I think probably Xfce, but KDE needs other packages updated.

Comment 7 Fedora Update System 2019-09-04 20:54:45 UTC
desktop-backgrounds-31.0.0-1.fc31, f31-backgrounds-31.0.2-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Rex Dieter 2019-09-04 21:36:01 UTC
I dream of a day when new backgrounds can land before freeze and there is no artificial rush to use them.

Comment 9 Adam Williamson 2019-09-04 22:43:03 UTC
Re-opening as KDE isn't fixed yet.

Rex: that would be nice, but then it would also be nice if KDE could set things up so it doesn't require special handling :P GNOME and Xfce don't - all the necessary configuration for them is in desktop-backgrounds, so just creating the new package and updating desktop-backgrounds is sufficient. KDE is the outlier there.

Note, the release criteria are set up such that if Rawhide just used a *Rawhide specific background* which never changed - ideally this would be an image which made it clear you were running some kind of non-stable release - we wouldn't get this crunch.

A Beta release using that notional 'Rawhide background' would not be a release blocker. This was intentional and I've always expected the folks in charge of backgrounds to set that up, but they never have. The reason we always get a Beta blocker is that Rawhide just uses the background from the most recent release, so when we branch, our new branched release has the background from the *previous* release. A Beta using the same background as a previous stable release is what breaks the Beta criteria. A Beta just using a 'wrong' background - but not one which was previously used in a stable release - does not violate the Beta criteria.

Comment 10 Kevin Kofler 2019-09-05 04:18:06 UTC
(In reply to Rex Dieter from comment #8)
> I dream of a day when new backgrounds can land before freeze and there is no
> artificial rush to use them.

I actually dream of a day when we would not pointlessly churn the backgrounds at each and every release. I would much rather have one well-picked permanent Fedora background that is part of a well-cured Fedora design that extends not only to all desktops, but also to all parts of the boot sequence (GRUB menu, Plymouth, GDM/SDDM/LightDM), where the design (e.g., the positioning of the UI elements in SDDM) should fit the background. (The last time we had something coming close was the Solar theme. But it was never ported from KDM to SDDM.) Such a design could and should then last for years, with development effort spent on developing and continuously improving the matching Plymouth and display manager themes rather than on creating yet another new background twice a year.

Comment 11 Adam Williamson 2019-09-12 17:09:50 UTC
I think we can close this at this point as no F31 desktop still seems to be using the F30 backgrounds. Several are using *wrong* backgrounds, but we have separate bugs for those.