Bug 1749086 - Needs updating for Fedora 31 background etc.
Summary: Needs updating for Fedora 31 background etc.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-settings
Version: 31
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa AcceptedBlocker AcceptedFreeze...
Depends On:
Blocks: BetaFreezeException, F31BetaFreezeException F31FinalBlocker, FinalBlocker 1744266
TreeView+ depends on / blocked
 
Reported: 2019-09-04 20:26 UTC by Adam Williamson
Modified: 2019-09-18 00:04 UTC (History)
12 users (show)

Fixed In Version: kde-settings-31.0-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-18 00:04:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 411876 None None None 2019-09-14 06:25:21 UTC

Description Adam Williamson 2019-09-04 20:26:34 UTC
As usual when we branch a new release, we need KDE packages updated to use the new desktop background. The update that provides the f31-backgrounds package and updated desktop-backgrounds is pending: https://bodhi.fedoraproject.org/updates/FEDORA-2019-8b2cccfabf . Can we please get all necessary KDE packages updated too? Thanks. This is a release blocker per Basic criterion "The default desktop background must be different from that of the last two stable releases."

Comment 1 Rex Dieter 2019-09-04 21:32:34 UTC
I dream of a day when new backgrounds can land before freeze and there is no artificial rush to get this in.  :-/

Comment 2 Rex Dieter 2019-09-04 21:35:09 UTC
Sorry, meant to add that to the linked bug.

Comment 3 Adam Williamson 2019-09-09 15:20:01 UTC
still, in the sad humdrum world in which we live, can this get done please? :)

Comment 4 Geoffrey Marr 2019-09-09 19:10:42 UTC
Discussed during the 2019-09-09 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker" was made as it violates the following criterion:

"The default desktop background must be different from that of the last two stable releases" (for the release-blocking KDE desktop)

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-09-09/f31-blocker-review.2019-09-09-16.00.txt

Comment 5 Fedora Update System 2019-09-11 01:17:19 UTC
FEDORA-2019-eaa33dc3b2 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-eaa33dc3b2

Comment 6 Rex Dieter 2019-09-11 13:11:29 UTC
Thanks for the assist, I've been unavailable for @dayjob conference

Comment 7 Fedora Update System 2019-09-11 15:37:18 UTC
kde-settings-31.0-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-eaa33dc3b2

Comment 8 Adam Williamson 2019-09-11 16:52:58 UTC
Sigh, we're still missing something here. With kde-settings-31.0-1.fc31 and f31-backgrounds-31.0.2-3.fc31 (which I built with one commit from 'upstream' that fixed a stray '30' that wasn't yet in the downstream package), I still get the "Next" background for a logged-in user session. I get the F31 background for the lock screen and the SDDM screen, though. Not really sure what's missing.

Comment 9 Adam Williamson 2019-09-11 16:54:01 UTC
rather than saying "still get the"...I should say "I get the Next background". Previously we got the F30 background, now we get the 'Next' one. This means we're not technically violating the Beta criteria any more which is good, but we should still fix this so we actually get the F31 background.

Comment 10 Kevin Kofler 2019-09-11 17:09:03 UTC
I guess the metadata.desktop in f31-backgrounds-kde is not valid.

Comment 11 Adam Williamson 2019-09-11 17:15:03 UTC
well, per https://github.com/fedoradesign/backgrounds/issues/16 there are actually *two of them*...

indeed, desktop-file-validate passes on /usr/share/plasma/desktoptheme/F31/metadata.desktop but fails on /usr/share/plasma/desktoptheme/F31/metadata.desktop . If I overwrite /usr/share/plasma/desktoptheme/F31/metadata.desktop with a copy of /usr/share/plasma/desktoptheme/F31/metadata.desktop and reboot...

nope, I still get the Last background. Sigh.

Comment 12 Adam Williamson 2019-09-12 17:28:46 UTC
As discussed in the Go/No-Go Meeting today, this is moved to Final blocker (as we're not using the F30 background any more, but aren't using the correct F31 background). Also accepted as an FE for Beta, in case we slip and figure out the fix in the meantime, obviously it'd be nice to ship Beta with the *correct* background.

Comment 13 Fedora Update System 2019-09-12 20:00:28 UTC
kde-settings-31.0-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Adam Williamson 2019-09-12 20:02:54 UTC
Re-opening because the bug isn't really fixed yet, we don't have the *right* background.

Comment 15 Rex Dieter 2019-09-12 20:19:57 UTC
Appears f31-backgrounds-kde config file
/usr/share/plasma/desktoptheme/F31/metadata.desktop
is malformed, some section headings were renamed from f30's version:
[Settings] => [X-Settings]
[Wallpaper] => [X-Wallpaper]
[Branding] => [X-Branding]
[ContrastEffect] => [X-ContrastEffect]

this is most likely why it doesn't work as expected.   I'll go test that theory now.

Comment 16 Adam Williamson 2019-09-12 20:32:11 UTC
I don't think it is. I've tried changing both metadata files to have the same contents as the other, but either way around it still doesn't work.

Comment 17 Rex Dieter 2019-09-12 20:38:32 UTC
Confirmed, once I put those back to match f30, things work expected in my quick testing (for me).  My testing on f30:  
1.  edit plasmarc:
[Theme]
name=F31

2.  Edit F31/metadata.desktop as described

3.  Create new user

4.  Login as new user, see them using the expected F31 wallpaper

Comment 18 Adam Williamson 2019-09-12 20:39:51 UTC
Oh wait. You have to create a new user? The fix won't apply to an existing user?

Comment 19 Rex Dieter 2019-09-12 20:40:59 UTC
Right, Note: I think this test will not work:

login as new user, see wrong wallpaper

edit stuff, whether that's plasmarc or F31/metadata.desktop

login as that same user, still see wrong wallpaper

(because I think it only chooses the plasma defaults on first login)

Comment 20 Rex Dieter 2019-09-12 20:42:53 UTC
or you can simulate a first login by deleting that users' ~/.config/plasma*  files

Comment 21 Adam Williamson 2019-09-12 20:43:56 UTC
ah well, that explains a lot.

Comment 22 Fedora Update System 2019-09-13 00:40:26 UTC
FEDORA-2019-6004dba64a has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-6004dba64a

Comment 23 Raphael Groner 2019-09-13 15:56:59 UTC
There a lot of taskotron errors reported from rpmgrill.
https://taskotron.fedoraproject.org/artifacts/all/88bee3c8-d5be-11e9-a807-52540077ca13/tests.yml/rpmgrill.json

Comment 24 Adam Williamson 2019-09-13 16:11:01 UTC
These are all bogus. See https://bugs.kde.org/show_bug.cgi?id=411876 .

Comment 25 Fedora Update System 2019-09-14 01:40:03 UTC
f31-backgrounds-31.0.2-4.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-6004dba64a

Comment 26 Fedora Update System 2019-09-14 05:04:02 UTC
FEDORA-2019-d7fbbec3ae has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d7fbbec3ae

Comment 27 Raphael Groner 2019-09-14 06:25:21 UTC
(In reply to Adam Williamson from comment #24)
> These are all bogus. See https://bugs.kde.org/show_bug.cgi?id=411876 .

Still with the new update, of course.

Comment 28 Fedora Update System 2019-09-15 01:13:27 UTC
f31-backgrounds-31.0.3-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d7fbbec3ae

Comment 29 Fedora Update System 2019-09-18 00:04:42 UTC
f31-backgrounds-31.0.3-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.