Bug 1745659

Summary: Failed to reload NetworkManager.servce
Product: [Fedora] Fedora Reporter: Lukas Slebodnik <lslebodn>
Component: NetworkManagerAssignee: Lubomir Rintel <lkundrak>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 31CC: bgalvani, dcbw, fgiudici, gnome-sig, john.j5live, jpazdziora, lkundrak, mclasen, mpitt, rhughes, rstrode, sandmann
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: NetworkManager-1.20.10-1.fc31 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-01-20 01:43:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Lukas Slebodnik 2019-08-26 15:13:07 UTC
Description of problem:
Failed to reload NetworkManager.servce

Version-Release number of selected component (if applicable):
rpm -qf /usr/lib/systemd/system/NetworkManager.service
NetworkManager-1.20.0-3.fc31.x86_64

How reproducible:
Deterministic

Steps to Reproduce:
1. Install minimal version of os with NetworkManager

#ensure that NM is running
2. systemctl status --lines 0 NetworkManager.service
3. systemctl reload NetworkManager.service

Actual results:
sh-5.0# systemctl status --lines 0 NetworkManager.service | cat
● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2019-08-26 14:03:22 EDT; 2h 53min left
     Docs: man:NetworkManager(8)
 Main PID: 684 (NetworkManager)
    Tasks: 3
   Memory: 12.3M
      CPU: 824ms
   CGroup: /system.slice/NetworkManager.service
           └─684 /usr/sbin/NetworkManager --no-daemon
systemctl reload NetworkManager.service
Job for NetworkManager.service failed.
See "systemctl status NetworkManager.service" and "journalctl -xe" for details.

Expected results:
NM reloaded/restarted without any problem.

Additional info:
dbus-tools is missing among dependencies.


sh-5.0# rpm -qf /usr/bin/dbus-send
error: file /usr/bin/dbus-send: No such file or directory
sh-5.0# grep /usr/bin/dbus-send /usr/lib/systemd/system/NetworkManager.service
ExecReload=/usr/bin/dbus-send --print-reply --system --type=method_call --dest=org.freedesktop.NetworkManager /org/freedesktop/NetworkManager org.freedesktop.NetworkManager.Reload uint32:0
sh-5.0# dnf repoquery --requires --resolve NetworkManager-1.20.0-3.fc31.x86_64 | sort -u
Last metadata expiration check: 0:58:41 ago on Mon 26 Aug 2019 10:13:35 AM EDT.
alternatives-0:1.11-5.fc31.x86_64
audit-libs-0:3.0-0.12.20190507gitf58ec40.fc31.x86_64
bash-0:5.0.7-3.fc31.x86_64
dbus-1:1.12.16-3.fc31.x86_64
glib2-0:2.61.2-1.fc31.x86_64
glibc-0:2.30-1.fc31.x86_64
gnutls-0:3.6.9-1.fc31.x86_64
libcurl-0:7.65.3-3.fc31.x86_64
libcurl-minimal-0:7.65.3-3.fc31.x86_64
libgcc-0:9.1.1-2.fc31.1.x86_64
libndp-0:1.7-4.fc31.x86_64
libpsl-0:0.21.0-2.fc31.x86_64
libselinux-0:2.9-5.fc31.x86_64
libuuid-0:2.34-2.fc31.x86_64
NetworkManager-libnm-1:1.20.0-3.fc31.x86_64
polkit-libs-0:0.116-3.fc31.x86_64
readline-0:8.0-3.fc31.x86_64
systemd-0:243~rc2-1.fc31.x86_64
systemd-libs-0:243~rc2-1.fc31.x86_64

Comment 2 Jan Pazdziora 2020-01-07 12:32:12 UTC
The problem is still present with NetworkManager-1.20.8-1.fc31.x86_64.

The upstream pull request was merged three months ago. Any chance of respinning the build in Fedora 31 with the dependency added?

Comment 3 Fedora Update System 2020-01-16 19:50:59 UTC
NetworkManager-1.20.10-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-5dcde509cc

Comment 4 Fedora Update System 2020-01-20 01:43:33 UTC
NetworkManager-1.20.10-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 5 Martin Pitt 2020-01-30 17:19:23 UTC
*** Bug 1771422 has been marked as a duplicate of this bug. ***

Comment 6 Red Hat Bugzilla 2023-09-14 05:42:20 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 1000 days