Bug 1748531

Summary: Handling UID range namespace annotations when migrating an application from source to destination
Product: Migration Toolkit for Containers Reporter: John Matthews <jmatthew>
Component: GeneralAssignee: John Matthews <jmatthew>
Status: CLOSED DEFERRED QA Contact: Xin jiang <xjiang>
Severity: low Docs Contact: Avital Pinnick <apinnick>
Priority: unspecified    
Version: 1.3.0CC: dymurray, ernelson, gferrazs
Target Milestone: ---   
Target Release: 1.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-04-08 02:47:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description John Matthews 2019-09-03 19:19:50 UTC
This BZ is intended to track a possible RFE to improve how we handle UID range annotations on a migrated namespace.
Consider allowing a user to opt out of the migration of UID range.


When an application is migrated to a destination cluster the migration tool will currently preserve the annotations on a namespace of: 
"openshift.io/sa.scc.mcs"
"openshift.io/sa.scc.supplemental-groups"
"openshift.io/sa.scc.uid-range"

This is done to preserve the UID the containers ran as on the source side to be the same on destination side so the container on destination will retain access to any persisted data.

There is potential that this could lead to reusing the UID range of a namespace on destination cluster, either from an existing namespace or from a future created namespace given the same range as what we migrated over.


For background info this is related to:
https://github.com/fusor/openshift-migration-plugin/pull/8/files
https://github.com/fusor/openshift-migration-plugin/issues/20


Related Docs BZ:  
https://bugzilla.redhat.com/show_bug.cgi?id=1748440

Comment 5 Erik Nelson 2021-04-08 02:47:48 UTC
Closing as I have captured as an RFE here: https://issues.redhat.com/browse/MIG-606