Bug 1748440 - Document possible concern of migrating UID range from source cluster to destination could lead to UID range overlap with namespaces
Summary: Document possible concern of migrating UID range from source cluster to desti...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Migration Tooling
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.0
Assignee: Avital Pinnick
QA Contact: Xin jiang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-03 15:09 UTC by John Matthews
Modified: 2019-11-15 08:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:40:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:40:22 UTC

Description John Matthews 2019-09-03 15:09:12 UTC
We want to include a note in migration docs that for OCP 4.2 when migrating a namespace we will preserve the annotations on a namespace of:

"openshift.io/sa.scc.mcs"
"openshift.io/sa.scc.supplemental-groups"
"openshift.io/sa.scc.uid-range"

This could lead to potential overlap of UID ranges in namespaces on destination cluster.


In next release (OCP 4.3 timeframe) we will make this step optional so a user can opt out of it.


For background info this is related to:
https://github.com/fusor/openshift-migration-plugin/pull/8/files

https://github.com/fusor/openshift-migration-plugin/issues/20

Comment 7 Xin jiang 2019-10-08 14:53:43 UTC
Confirmed that this issue is addressed on doc.

Comment 8 errata-xmlrpc 2019-10-16 06:40:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.