Bug 1751556

Summary: syncop: Bail out if frame creation fails
Product: [Community] GlusterFS Reporter: Soumya Koduri <skoduri>
Component: coreAssignee: bugs <bugs>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7CC: bugs
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-15 13:21:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Soumya Koduri 2019-09-12 07:27:56 UTC
This bug was initially created as a copy of Bug #1748448

I am copying this bug because: 



Description of problem:

There could be cases (either due to insufficient memory or
corrupted mem-pool) due to which frame creation fails. Bail out
with error in such cases.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2019-09-12 07:34:06 UTC
REVIEW: https://review.gluster.org/23405 (core/syncop: Bail out if frame creation fails) posted (#1) for review on release-7 by soumya k

Comment 2 Worker Ant 2019-09-15 13:21:05 UTC
REVIEW: https://review.gluster.org/23405 (core/syncop: Bail out if frame creation fails) merged (#2) on release-7 by Rinku Kothiya