Bug 1748448 - syncop: Bail out if frame creation fails
Summary: syncop: Bail out if frame creation fails
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1746324
TreeView+ depends on / blocked
 
Reported: 2019-09-03 15:38 UTC by Soumya Koduri
Modified: 2019-09-12 07:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-12 07:22:42 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 23350 0 None Merged core/syncop: Bail out if frame creation fails 2019-09-12 07:22:41 UTC

Description Soumya Koduri 2019-09-03 15:38:43 UTC
Description of problem:

There could be cases (either due to insufficient memory or
corrupted mem-pool) due to which frame creation fails. Bail out
with error in such cases.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2019-09-03 15:43:05 UTC
REVIEW: https://review.gluster.org/23350 (core/syncop: Bail out if frame creation fails) posted (#1) for review on master by soumya k

Comment 2 Worker Ant 2019-09-12 07:22:42 UTC
REVIEW: https://review.gluster.org/23350 (core/syncop: Bail out if frame creation fails) merged (#3) on master by Amar Tumballi


Note You need to log in before you can comment on or make changes to this bug.