Bug 1753543

Summary: perl-Font-AFM for EL8
Product: [Fedora] Fedora EPEL Reporter: Xavier Bachelot <xavier>
Component: perl-Font-AFMAssignee: Tom "spot" Callaway <tcallawa>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel8CC: lxtnow, perl-devel, rc040203, rob.myers, tcallawa, tremble
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: perl-Font-AFM-1.20-31.el8.1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-10-19 17:03:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1757474    
Bug Blocks: 1749231, 1762271    

Description Xavier Bachelot 2019-09-19 09:15:56 UTC
Hi,

Could you please branch and build perl-FontAFM for EPEL 8 ?
It is in the dependency chain of another package I'd like to maintain in EPEL 8.

Regards,
Xavier

Comment 1 Xavier Bachelot 2019-09-19 16:32:29 UTC
master branch doesn't build against epel8 target because of a dependency on a file provides by a2ps which is used to run some optional test. See RHBZ#1581656.
With the "BuildRequires: %{_datadir}/a2ps/afm/phvr.afm" line removed, the package builds fine, so I think it's better not to request an EL8 build for a2ps.
https://koji.fedoraproject.org/koji/taskinfo?taskID=37743556

Comment 2 Fedora Update System 2019-10-04 07:20:47 UTC
FEDORA-EPEL-2019-9d98c5adb3 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-9d98c5adb3

Comment 3 Fedora Update System 2019-10-04 23:17:29 UTC
perl-Font-AFM-1.20-31.el8.1 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-9d98c5adb3

Comment 4 Fedora Update System 2019-10-19 17:03:15 UTC
perl-Font-AFM-1.20-31.el8.1 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.